Rocket.Surgery.Extensions.FluentValidation 6.2.0

.NET Standard 2.0
There is a newer version of this package available.
See the version list below for details.
dotnet add package Rocket.Surgery.Extensions.FluentValidation --version 6.2.0
NuGet\Install-Package Rocket.Surgery.Extensions.FluentValidation -Version 6.2.0
This command is intended to be used within the Package Manager Console in Visual Studio, as it uses the NuGet module's version of Install-Package.
<PackageReference Include="Rocket.Surgery.Extensions.FluentValidation" Version="6.2.0" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add Rocket.Surgery.Extensions.FluentValidation --version 6.2.0
#r "nuget: Rocket.Surgery.Extensions.FluentValidation, 6.2.0"
#r directive can be used in F# Interactive, C# scripting and .NET Interactive. Copy this into the interactive tool or source code of the script to reference the package.
// Install Rocket.Surgery.Extensions.FluentValidation as a Cake Addin
#addin nuget:?package=Rocket.Surgery.Extensions.FluentValidation&version=6.2.0

// Install Rocket.Surgery.Extensions.FluentValidation as a Cake Tool
#tool nuget:?package=Rocket.Surgery.Extensions.FluentValidation&version=6.2.0

Package Description

Product Versions
.NET net5.0 net5.0-windows net6.0 net6.0-android net6.0-ios net6.0-maccatalyst net6.0-macos net6.0-tvos net6.0-windows net7.0 net7.0-android net7.0-ios net7.0-maccatalyst net7.0-macos net7.0-tvos net7.0-windows
.NET Core netcoreapp2.0 netcoreapp2.1 netcoreapp2.2 netcoreapp3.0 netcoreapp3.1
.NET Standard netstandard2.0 netstandard2.1
.NET Framework net461 net462 net463 net47 net471 net472 net48
MonoAndroid monoandroid
MonoMac monomac
MonoTouch monotouch
Tizen tizen40 tizen60
Xamarin.iOS xamarinios
Xamarin.Mac xamarinmac
Xamarin.TVOS xamarintvos
Xamarin.WatchOS xamarinwatchos
Compatible target framework(s)
Additional computed target framework(s)
Learn more about Target Frameworks and .NET Standard.

NuGet packages (6)

Showing the top 5 NuGet packages that depend on Rocket.Surgery.Extensions.FluentValidation:

Package Downloads
Rocket.Surgery.AspNetCore.FluentValidation

Package Description

Rocket.Surgery.Extensions.FluentValidation.Vue

Package Description

Rocket.Surgery.Extensions.FluentValidation.AspNetCore

Package Description

Rocket.Surgery.Extensions.FluentValidation.MediatR

Package Description

Rocket.Surgery.Conventions.FluentValidation

Package Description

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
7.0.0 3,051 12/9/2020
7.0.0-beta.4 405 12/4/2020
7.0.0-beta.3 1,194 8/19/2020
7.0.0-beta.2 1,678 7/11/2020
7.0.0-beta.1 552 6/28/2020
6.3.1 8,403 1/18/2020
6.3.0 498 1/13/2020
6.2.3 683 12/28/2019
6.2.2 741 12/16/2019
6.2.1 663 12/16/2019
6.2.0 662 12/16/2019
6.1.2 940 11/21/2019
6.1.1 1,079 10/16/2019
6.1.0 709 10/16/2019
6.0.1 524 10/11/2019
6.0.0 708 9/27/2019

## v6.2.0


As part of this release we had [16 issues](https://github.com/RocketSurgeonsGuild/FluentValidation.Extensions/milestone/23?closed=1) closed.


__ dependenciess__

- [__#148__](https://github.com/RocketSurgeonsGuild/FluentValidation.Extensions/pull/148) Bump Rocket.Surgery.Nuke.DotNetCore from 0.8.3 to 0.9.2
- [__#147__](https://github.com/RocketSurgeonsGuild/FluentValidation.Extensions/pull/147) Bump ReportGenerator from 4.3.6 to 4.3.8
- [__#144__](https://github.com/RocketSurgeonsGuild/FluentValidation.Extensions/pull/144) Bump JetBrains.ReSharper.CommandLineTools from 2019.3.0-eap07 to 2019.3.0
- [__#142__](https://github.com/RocketSurgeonsGuild/FluentValidation.Extensions/pull/142) Bump Bogus from 28.4.3 to 28.4.4
- [__#141__](https://github.com/RocketSurgeonsGuild/FluentValidation.Extensions/pull/141) Bump FluentValidation.AspNetCore from 8.5.1 to 8.6.0
- [__#140__](https://github.com/RocketSurgeonsGuild/FluentValidation.Extensions/pull/140) Bump FluentValidation from 8.5.1 to 8.6.0
- [__#139__](https://github.com/RocketSurgeonsGuild/FluentValidation.Extensions/pull/139) Bump Bogus from 28.4.1 to 28.4.3
- [__#138__](https://github.com/RocketSurgeonsGuild/FluentValidation.Extensions/pull/138) Bump Microsoft.NETFramework.ReferenceAssemblies from 1.0.0-preview.2 to 1.0.0
- [__#136__](https://github.com/RocketSurgeonsGuild/FluentValidation.Extensions/pull/136) Bump JetBrains.ReSharper.CommandLineTools from 2019.3.0-eap06 to 2019.3.0-eap07
- [__#135__](https://github.com/RocketSurgeonsGuild/FluentValidation.Extensions/pull/135) Bump Microsoft.SourceLink.GitHub from 1.0.0-beta2-19554-01 to 1.0.0
- [__#134__](https://github.com/RocketSurgeonsGuild/FluentValidation.Extensions/pull/134) Bump FakeItEasy from 5.4.1 to 5.5.0
- [__#133__](https://github.com/RocketSurgeonsGuild/FluentValidation.Extensions/pull/133) Bump FakeItEasy.Analyzer.CSharp from 5.4.1 to 5.5.0
- [__#132__](https://github.com/RocketSurgeonsGuild/FluentValidation.Extensions/pull/132) Bump Microsoft.CodeAnalysis.FxCopAnalyzers from 2.9.7 to 2.9.8
- [__#131__](https://github.com/RocketSurgeonsGuild/FluentValidation.Extensions/pull/131) Bump Microsoft.CodeAnalysis.PublicApiAnalyzers from 2.9.7 to 2.9.8
- [__#130__](https://github.com/RocketSurgeonsGuild/FluentValidation.Extensions/pull/130) Bump Rocket.Surgery.Extensions.DependencyInjection.Abstractions from 9.0.6 to 9.0.7
- [__#129__](https://github.com/RocketSurgeonsGuild/FluentValidation.Extensions/pull/129) Bump Rocket.Surgery.Conventions from 9.0.6 to 9.0.7




## Changes:

* Merge pull request #148 from RocketSurgeonsGuild/dependabot/nuget/master/Rocket.Surgery.Nuke.DotNetCore-0.9.2
* Merge pull request #142 from RocketSurgeonsGuild/dependabot/nuget/master/Bogus-28.4.4
* Bump Rocket.Surgery.Nuke.DotNetCore from 0.8.3 to 0.9.2
* Merge pull request #147 from RocketSurgeonsGuild/dependabot/nuget/master/ReportGenerator-4.3.8
* Bump ReportGenerator from 4.3.6 to 4.3.8
* Merge pull request #144 from RocketSurgeonsGuild/dependabot/nuget/master/JetBrains.ReSharper.CommandLineTools-2019.3.0
* Updated dependabot config
* Bump JetBrains.ReSharper.CommandLineTools
* Bump Bogus from 28.4.3 to 28.4.4
* Updated dependencies
<details><summary><b>See More</b></summary>

* Merge pull request #135 from RocketSurgeonsGuild/dependabot/nuget/master/Microsoft.SourceLink.GitHub-1.0.0
* Merge pull request #140 from RocketSurgeonsGuild/dependabot/nuget/master/FluentValidation-8.6.0
* Merge pull request #134 from RocketSurgeonsGuild/dependabot/nuget/master/FakeItEasy-5.5.0
* Bump Microsoft.SourceLink.GitHub from 1.0.0-beta2-19554-01 to 1.0.0
* Merge pull request #138 from RocketSurgeonsGuild/dependabot/nuget/master/Microsoft.NETFramework.ReferenceAssemblies-1.0.0
* Bump FluentValidation from 8.5.1 to 8.6.0
* Bump FakeItEasy from 5.4.1 to 5.5.0
* Merge pull request #141 from RocketSurgeonsGuild/dependabot/nuget/master/FluentValidation.AspNetCore-8.6.0
* Bump Microsoft.NETFramework.ReferenceAssemblies
* Merge pull request #132 from RocketSurgeonsGuild/dependabot/nuget/master/Microsoft.CodeAnalysis.FxCopAnalyzers-2.9.8
* Merge pull request #139 from RocketSurgeonsGuild/dependabot/nuget/master/Bogus-28.4.3
* Merge pull request #136 from RocketSurgeonsGuild/dependabot/nuget/master/JetBrains.ReSharper.CommandLineTools-2019.3.0-eap07
* Merge pull request #133 from RocketSurgeonsGuild/dependabot/nuget/master/FakeItEasy.Analyzer.CSharp-5.5.0
* Bump Microsoft.CodeAnalysis.FxCopAnalyzers from 2.9.7 to 2.9.8
* Merge pull request #131 from RocketSurgeonsGuild/dependabot/nuget/master/Microsoft.CodeAnalysis.PublicApiAnalyzers-2.9.8
* Bump FluentValidation.AspNetCore from 8.5.1 to 8.6.0
* Bump Bogus from 28.4.1 to 28.4.3
* Bump JetBrains.ReSharper.CommandLineTools
* Bump FakeItEasy.Analyzer.CSharp from 5.4.1 to 5.5.0
* Bump Microsoft.CodeAnalysis.PublicApiAnalyzers from 2.9.7 to 2.9.8
* Updated deps
* Added formatting
* +semver:minor
* Updated dependencies and added request exception handling
* Updated shipped apis
* Added public api and fixed warnings
* Merge branch 'master' of github.com:RocketSurgeonsGuild/FluentValidation.Extensions
* Added editorconfig and publicapi
* Merge pull request #130 from RocketSurgeonsGuild/dependabot/nuget/master/Rocket.Surgery.Extensions.DependencyInjection.Abstractions-9.0.7
* Merge pull request #129 from RocketSurgeonsGuild/dependabot/nuget/master/Rocket.Surgery.Conventions-9.0.7
* Bump Rocket.Surgery.Extensions.DependencyInjection.Abstractions
* Bump Rocket.Surgery.Conventions from 9.0.6 to 9.0.7

This list of changes was [auto generated](https://rocketsurgeonsguild.visualstudio.com/Libraries/_build/results?buildId=7216&view=logs).</details>