Rocket.Surgery.Extensions.FluentValidation 6.0.1

.NET Standard 2.0
There is a newer version of this package available.
See the version list below for details.
dotnet add package Rocket.Surgery.Extensions.FluentValidation --version 6.0.1
NuGet\Install-Package Rocket.Surgery.Extensions.FluentValidation -Version 6.0.1
This command is intended to be used within the Package Manager Console in Visual Studio, as it uses the NuGet module's version of Install-Package.
<PackageReference Include="Rocket.Surgery.Extensions.FluentValidation" Version="6.0.1" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add Rocket.Surgery.Extensions.FluentValidation --version 6.0.1
#r "nuget: Rocket.Surgery.Extensions.FluentValidation, 6.0.1"
#r directive can be used in F# Interactive, C# scripting and .NET Interactive. Copy this into the interactive tool or source code of the script to reference the package.
// Install Rocket.Surgery.Extensions.FluentValidation as a Cake Addin
#addin nuget:?package=Rocket.Surgery.Extensions.FluentValidation&version=6.0.1

// Install Rocket.Surgery.Extensions.FluentValidation as a Cake Tool
#tool nuget:?package=Rocket.Surgery.Extensions.FluentValidation&version=6.0.1

Package Description

Product Versions
.NET net5.0 net5.0-windows net6.0 net6.0-android net6.0-ios net6.0-maccatalyst net6.0-macos net6.0-tvos net6.0-windows net7.0 net7.0-android net7.0-ios net7.0-maccatalyst net7.0-macos net7.0-tvos net7.0-windows
.NET Core netcoreapp2.0 netcoreapp2.1 netcoreapp2.2 netcoreapp3.0 netcoreapp3.1
.NET Standard netstandard2.0 netstandard2.1
.NET Framework net461 net462 net463 net47 net471 net472 net48
MonoAndroid monoandroid
MonoMac monomac
MonoTouch monotouch
Tizen tizen40 tizen60
Xamarin.iOS xamarinios
Xamarin.Mac xamarinmac
Xamarin.TVOS xamarintvos
Xamarin.WatchOS xamarinwatchos
Compatible target framework(s)
Additional computed target framework(s)
Learn more about Target Frameworks and .NET Standard.

NuGet packages (6)

Showing the top 5 NuGet packages that depend on Rocket.Surgery.Extensions.FluentValidation:

Package Downloads
Rocket.Surgery.AspNetCore.FluentValidation

Package Description

Rocket.Surgery.Extensions.FluentValidation.Vue

Package Description

Rocket.Surgery.Extensions.FluentValidation.AspNetCore

Package Description

Rocket.Surgery.Extensions.FluentValidation.MediatR

Package Description

Rocket.Surgery.Conventions.FluentValidation

Package Description

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
7.0.0 3,051 12/9/2020
7.0.0-beta.4 405 12/4/2020
7.0.0-beta.3 1,194 8/19/2020
7.0.0-beta.2 1,678 7/11/2020
7.0.0-beta.1 552 6/28/2020
6.3.1 8,418 1/18/2020
6.3.0 498 1/13/2020
6.2.3 683 12/28/2019
6.2.2 741 12/16/2019
6.2.1 663 12/16/2019
6.2.0 662 12/16/2019
6.1.2 940 11/21/2019
6.1.1 1,079 10/16/2019
6.1.0 709 10/16/2019
6.0.1 524 10/11/2019
6.0.0 708 9/27/2019

## v6.0.1


As part of this release we had [22 issues](https://github.com/RocketSurgeonsGuild/FluentValidation.Extensions/milestone/17?closed=1) closed.


__ dependenciess__

- [__#82__](https://github.com/RocketSurgeonsGuild/FluentValidation.Extensions/pull/82) Bump Rocket.Surgery.Extensions.CommandLine from 9.0.3 to 9.0.4
- [__#81__](https://github.com/RocketSurgeonsGuild/FluentValidation.Extensions/pull/81) Bump Rocket.Surgery.Conventions from 9.0.3 to 9.0.4
- [__#79__](https://github.com/RocketSurgeonsGuild/FluentValidation.Extensions/pull/79) Bump Rocket.Surgery.Extensions.CommandLine.Abstractions from 9.0.3 to 9.0.4
- [__#78__](https://github.com/RocketSurgeonsGuild/FluentValidation.Extensions/pull/78) Bump Rocket.Surgery.Conventions.Abstractions from 9.0.3 to 9.0.4
- [__#77__](https://github.com/RocketSurgeonsGuild/FluentValidation.Extensions/pull/77) Bump Rocket.Surgery.Extensions.DependencyInjection from 9.0.3 to 9.0.4
- [__#76__](https://github.com/RocketSurgeonsGuild/FluentValidation.Extensions/pull/76) Bump Bogus from 28.3.1 to 28.3.2
- [__#74__](https://github.com/RocketSurgeonsGuild/FluentValidation.Extensions/pull/74) Bump Nuke.Common from 0.22.1 to 0.22.2
- [__#73__](https://github.com/RocketSurgeonsGuild/FluentValidation.Extensions/pull/73) Bump Rocket.Surgery.Extensions from 1.0.6 to 2.0.0
- [__#72__](https://github.com/RocketSurgeonsGuild/FluentValidation.Extensions/pull/72) Bump Rocket.Surgery.Extensions.DependencyInjection from 9.0.2 to 9.0.3
- [__#71__](https://github.com/RocketSurgeonsGuild/FluentValidation.Extensions/pull/71) Bump Rocket.Surgery.Conventions.Abstractions from 9.0.2 to 9.0.3
- [__#70__](https://github.com/RocketSurgeonsGuild/FluentValidation.Extensions/pull/70) Bump Rocket.Surgery.Extensions.CommandLine.Abstractions from 9.0.2 to 9.0.3
- [__#69__](https://github.com/RocketSurgeonsGuild/FluentValidation.Extensions/pull/69) Bump Rocket.Surgery.Extensions.DependencyInjection.Abstractions from 9.0.2 to 9.0.3
- [__#68__](https://github.com/RocketSurgeonsGuild/FluentValidation.Extensions/pull/68) Bump Rocket.Surgery.Extensions.CommandLine from 9.0.2 to 9.0.3
- [__#67__](https://github.com/RocketSurgeonsGuild/FluentValidation.Extensions/pull/67) Bump Rocket.Surgery.Conventions from 9.0.2 to 9.0.3
- [__#66__](https://github.com/RocketSurgeonsGuild/FluentValidation.Extensions/pull/66) Bump Rocket.Surgery.Extensions.DependencyInjection from 9.0.0 to 9.0.2
- [__#65__](https://github.com/RocketSurgeonsGuild/FluentValidation.Extensions/pull/65) Bump Rocket.Surgery.Conventions.Abstractions from 9.0.0 to 9.0.2
- [__#64__](https://github.com/RocketSurgeonsGuild/FluentValidation.Extensions/pull/64) Bump Rocket.Surgery.Extensions.DependencyInjection.Abstractions from 9.0.0 to 9.0.2
- [__#63__](https://github.com/RocketSurgeonsGuild/FluentValidation.Extensions/pull/63) Bump Rocket.Surgery.Conventions from 9.0.0 to 9.0.2
- [__#61__](https://github.com/RocketSurgeonsGuild/FluentValidation.Extensions/pull/61) Bump Rocket.Surgery.Extensions.CommandLine.Abstractions from 9.0.0 to 9.0.2
- [__#62__](https://github.com/RocketSurgeonsGuild/FluentValidation.Extensions/pull/62) Bump Rocket.Surgery.Extensions.CommandLine from 9.0.0 to 9.0.2
- [__#60__](https://github.com/RocketSurgeonsGuild/FluentValidation.Extensions/pull/60) Bump Rocket.Surgery.Extensions.Testing.FakeItEasy from 2.1.0 to 2.1.2
- [__#59__](https://github.com/RocketSurgeonsGuild/FluentValidation.Extensions/pull/59) Bump Humanizer.Core from 2.7.2 to 2.7.9




## Changes:

* Updated to latest
* Merge pull request #82 from RocketSurgeonsGuild/dependabot/nuget/master/Rocket.Surgery.Extensions.CommandLine-9.0.4
* Bump Rocket.Surgery.Extensions.CommandLine from 9.0.3 to 9.0.4
* Merge pull request #79 from RocketSurgeonsGuild/dependabot/nuget/master/Rocket.Surgery.Extensions.CommandLine.Abstractions-9.0.4
* Merge pull request #81 from RocketSurgeonsGuild/dependabot/nuget/master/Rocket.Surgery.Conventions-9.0.4
* Bump Rocket.Surgery.Conventions from 9.0.3 to 9.0.4
* Bump Rocket.Surgery.Extensions.CommandLine.Abstractions
* Merge pull request #78 from RocketSurgeonsGuild/dependabot/nuget/master/Rocket.Surgery.Conventions.Abstractions-9.0.4
* Merge pull request #77 from RocketSurgeonsGuild/dependabot/nuget/master/Rocket.Surgery.Extensions.DependencyInjection-9.0.4
* Bump Rocket.Surgery.Conventions.Abstractions from 9.0.3 to 9.0.4
<details><summary><b>See More</b></summary>

* Bump Rocket.Surgery.Extensions.DependencyInjection from 9.0.3 to 9.0.4
* Updated deps
* Merge pull request #76 from RocketSurgeonsGuild/dependabot/nuget/master/Bogus-28.3.2
* Updated build netstandard version
* Bump Bogus from 28.3.1 to 28.3.2
* Updated pipelines
* Merge branch 'master' of github.com:RocketSurgeonsGuild/FluentValidation.Extensions
* Updated pipeslines
* Bump Nuke.Common from 0.22.1 to 0.22.2 (#74)
* Merge pull request #73 from RocketSurgeonsGuild/dependabot/nuget/master/Rocket.Surgery.Extensions-2.0.0
* Updated config
* Bump Rocket.Surgery.Extensions from 1.0.6 to 2.0.0
* Merge pull request #68 from RocketSurgeonsGuild/dependabot/nuget/master/Rocket.Surgery.Extensions.CommandLine-9.0.3
* Bump Rocket.Surgery.Extensions.CommandLine from 9.0.2 to 9.0.3
* Merge pull request #72 from RocketSurgeonsGuild/dependabot/nuget/master/Rocket.Surgery.Extensions.DependencyInjection-9.0.3
* Bump Rocket.Surgery.Extensions.DependencyInjection from 9.0.2 to 9.0.3
* Merge pull request #70 from RocketSurgeonsGuild/dependabot/nuget/master/Rocket.Surgery.Extensions.CommandLine.Abstractions-9.0.3
* Bump Rocket.Surgery.Extensions.CommandLine.Abstractions
* Merge pull request #71 from RocketSurgeonsGuild/dependabot/nuget/master/Rocket.Surgery.Conventions.Abstractions-9.0.3
* Merge pull request #69 from RocketSurgeonsGuild/dependabot/nuget/master/Rocket.Surgery.Extensions.DependencyInjection.Abstractions-9.0.3
* Bump Rocket.Surgery.Conventions.Abstractions from 9.0.2 to 9.0.3
* Merge pull request #67 from RocketSurgeonsGuild/dependabot/nuget/master/Rocket.Surgery.Conventions-9.0.3
* Updated azure piplines for batching
* Bump Rocket.Surgery.Extensions.DependencyInjection.Abstractions
* Bump Rocket.Surgery.Conventions from 9.0.2 to 9.0.3
* Updated azure piplines for batching
* Merge pull request #66 from RocketSurgeonsGuild/dependabot/nuget/Rocket.Surgery.Extensions.DependencyInjection-9.0.2
* Merge pull request #59 from RocketSurgeonsGuild/dependabot/nuget/Humanizer.Core-2.7.9
* Merge pull request #63 from RocketSurgeonsGuild/dependabot/nuget/Rocket.Surgery.Conventions-9.0.2
* Bump Rocket.Surgery.Conventions from 9.0.0 to 9.0.2
* Merge pull request #65 from RocketSurgeonsGuild/dependabot/nuget/Rocket.Surgery.Conventions.Abstractions-9.0.2
* Merge branch 'master' of github.com:RocketSurgeonsGuild/FluentValidation.Extensions
* Updated pipelines
* Bump Rocket.Surgery.Extensions.DependencyInjection from 9.0.0 to 9.0.2
* Bump Rocket.Surgery.Conventions.Abstractions from 9.0.0 to 9.0.2
* Merge pull request #61 from RocketSurgeonsGuild/dependabot/nuget/Rocket.Surgery.Extensions.CommandLine.Abstractions-9.0.2
* Bump Rocket.Surgery.Extensions.CommandLine.Abstractions
* Merge pull request #60 from RocketSurgeonsGuild/dependabot/nuget/Rocket.Surgery.Extensions.Testing.FakeItEasy-2.1.2
* Merge pull request #62 from RocketSurgeonsGuild/dependabot/nuget/Rocket.Surgery.Extensions.CommandLine-9.0.2
* Merge pull request #64 from RocketSurgeonsGuild/dependabot/nuget/Rocket.Surgery.Extensions.DependencyInjection.Abstractions-9.0.2
* Updated coverage settings
* Bump Rocket.Surgery.Extensions.DependencyInjection.Abstractions
* Bump Rocket.Surgery.Extensions.CommandLine from 9.0.0 to 9.0.2
* Bump Rocket.Surgery.Extensions.Testing.FakeItEasy from 2.1.0 to 2.1.2
* Bump Humanizer.Core from 2.7.2 to 2.7.9
* Updated deps
* Merge pull request #58 from RocketSurgeonsGuild/dependabot/nuget/Rocket.Surgery.Extensions.Testing.FakeItEasy-2.1.0
* Bump Rocket.Surgery.Extensions.Testing.FakeItEasy from 2.0.2 to 2.1.0

This list of changes was [auto generated](https://rocketsurgeonsguild.visualstudio.com/Libraries/_build/results?buildId=4586&view=logs).</details>