Scalesque 0.7.5

.NET Framework 3.5
There is a newer version of this package available.
See the version list below for details.
dotnet add package Scalesque --version 0.7.5
NuGet\Install-Package Scalesque -Version 0.7.5
This command is intended to be used within the Package Manager Console in Visual Studio, as it uses the NuGet module's version of Install-Package.
<PackageReference Include="Scalesque" Version="0.7.5" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add Scalesque --version 0.7.5
#r "nuget: Scalesque, 0.7.5"
#r directive can be used in F# Interactive, C# scripting and .NET Interactive. Copy this into the interactive tool or source code of the script to reference the package.
// Install Scalesque as a Cake Addin
#addin nuget:?package=Scalesque&version=0.7.5

// Install Scalesque as a Cake Tool
#tool nuget:?package=Scalesque&version=0.7.5

A micro library for coding in a functional style using c#.  Features Option<T>, Either<T,U>, pattern matching with exatractors, partially applied functions, scalaz inspired Validation<T,U> and various collection methods like fold and reduce.

Product Versions
.NET Framework net35-client net40-client
Compatible target framework(s)
Additional computed target framework(s)
Learn more about Target Frameworks and .NET Standard.

This package has no dependencies.

NuGet packages (1)

Showing the top 1 NuGet packages that depend on Scalesque:

Package Downloads
EventSaucing

An event source stack based on NEventStore and Akka

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
1.0.3 702 6/24/2021
0.8.0 1,672 4/6/2017
0.7.5 1,739 6/11/2012
0.7.4 1,155 5/9/2012
0.7.3 1,097 5/3/2012
0.7.1 1,146 4/22/2012
0.7.0 1,156 4/22/2012

Added exception wrapper.  Added non-lazy GetOrElse for Option.  Dropped if expressions as this was a bad idea (breaking change), replace with ternary expression.