ILAsm 4.5.1

There is a newer version of this package available.
See the version list below for details.
dotnet add package ILAsm --version 4.5.1
NuGet\Install-Package ILAsm -Version 4.5.1
This command is intended to be used within the Package Manager Console in Visual Studio, as it uses the NuGet module's version of Install-Package.
<PackageReference Include="ILAsm" Version="4.5.1" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add ILAsm --version 4.5.1
#r "nuget: ILAsm, 4.5.1"
#r directive can be used in F# Interactive and Polyglot Notebooks. Copy this into the interactive tool or source code of the script to reference the package.
// Install ILAsm as a Cake Addin
#addin nuget:?package=ILAsm&version=4.5.1

// Install ILAsm as a Cake Tool
#tool nuget:?package=ILAsm&version=4.5.1

This package contains executable ILAsm / ILDasm - v4.5.1 :: *v4.5.22220.0*
       [ Win.x86 and Win.x64 ]
       [ .NET Core Runtime (CoreCLR) *v1.0.4 ]
       
       `* - The base of version, i.e. it can be different from official release`
       
       _ _ _ _ _ _
       Compiled from https://github.com/3F/coreclr
       The MIT License (MIT)
       
       MSBuild Properties:
       * $(ILAsm_RootPkg) - path to root folder of this package after install.
       * $(ILAsm_PathToBin) - path to `\bin` folder., e.g.: $(ILAsm_PathToBin)Win.x86\ilasm.exe

       ~~~~~~~~
       Alternative to get it:
       ==========================================
       msbuild gnt.core /p:ngpackages="ILAsm/4.5.1"
       ==========================================
       * https://github.com/3F/GetNuTool

Product Compatible and additional computed target framework versions.
.NET Framework net is compatible. 
native native is compatible. 
Compatible target framework(s)
Included target framework(s) (in package)
Learn more about Target Frameworks and .NET Standard.

This package has no dependencies.

NuGet packages

This package is not used by any NuGet packages.

GitHub repositories (1)

Showing the top 1 popular GitHub repositories that depend on ILAsm:

Repository Stars
3F/DllExport
.NET DllExport with .NET Core support (aka 3F/DllExport aka DllExport.bat)
Version Downloads Last updated
4.700.2 3,555 12/8/2019
4.700.1 1,767 11/3/2019
4.5.1.1 5,135 12/8/2016
4.5.1 3,996 11/3/2016

https://github.com/3F/coreclr
       - - - - - - - - - - - - - - - -

       # coreclr \ ILAsm

       [v4.5.1]

           * FIXED: Fixed using of cvtres (.res - obj COFF-format) in mscorpe.
                    Possible crash: https://github.com/3F/coreclr/issues/2
                    Related Issue: https://github.com/3F/DllExport/issues/17
                  
           * NEW: Implemented additional searching of the converters of resources:
                  Environment PATH, local directory, and other additional from user path.
                  Now it also can be wrapped like ` mytool.cmd - cvtres.exe %* ` etc.
                  
           * NEW: Added new /CVRES (/CVR) key to ilasm.exe
                  `/CVRES={path_to_file}   Set path to cvtres tool: /CVR=cvtres.exe /CVR=tool\cvtres.cmd /CVR=D:\tool\`
                  
           * NOTE: based on 4.5.22220.0  / coreclr 1.0.4
                            ^ ^  ^    ^
                            | |  |    |-- VER_FILEVERSIONREVISION
                            | |  |------- VER_FILEVERSIONBUILD
                            | |---------- VER_FILEVERSIONMINOR
                            |------------ VER_MAJORVERSION