FastYolo 11.1.1

.NET 5.0
There is a newer version of this package available.
See the version list below for details.
Install-Package FastYolo -Version 11.1.1
dotnet add package FastYolo --version 11.1.1
<PackageReference Include="FastYolo" Version="11.1.1" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add FastYolo --version 11.1.1
The NuGet Team does not provide support for this client. Please contact its maintainers for support.
#r "nuget: FastYolo, 11.1.1"
#r directive can be used in F# Interactive, C# scripting and .NET Interactive. Copy this into the interactive tool or source code of the script to reference the package.
// Install FastYolo as a Cake Addin
#addin nuget:?package=FastYolo&version=11.1.1

// Install FastYolo as a Cake Tool
#tool nuget:?package=FastYolo&version=11.1.1
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

Fast .NET Yolo library, requires Cuda 11.1+ to be installed to work, it will use the GPU for processing (which is many times faster than using the CPU version disabled in this release). Since v11.1 this library requires Cuda 11.1 and a GPU with shader model 7.5 (on Windows, e.g. RTX 20x0+) and 5.3 (Jetson Nano)+7.2 (Jetson Xavier) for half-float optimizations with even faster tensor core computations (which will not work on 1660 GPUs, which have no tensor cores, those will switch back to cuda cores, sm 7.5 as well), older GPUs with sm 5.2+ (9x0 series, 10x0 series and jetson nano) are not supported anymore, use FastYolo v1.0.4 for that. More details about Cuda Cores and Compute Capability: https://www.geeks3d.com/20100606/gpu-computing-nvidia-cuda-compute-capability-comparative-table/

Includes the .dll files for Yolo Darknet Wrapper, Real-Time Object Detection (AlexeyAB/darknet with additions and fixes here: https://github.com/maalik0786/darknet), including cudnn64_8.dll, opencv_world440.dll and pthreadVC2.dll as needed by the yolo_cpp_dll implementation. Tested on Windows x64, Linux AMD64 and ARM64 (Jetson/Raspi4). On Linux OpenCV and Cuda+CudNN must be installed already, libdarknet and libpthread are provided for both AMD64 and ARM64 inside the nuget package.

Since v11.1 the default resolution is now 640x480, which works a bit better for most pictures and camera data. v1.0.4 adds resize detection and will output a warning in the console and allow to check via the CheckIfImageWasResized method if any resize happened. Resizing should not be done dynamically in the darknet library, extra memory would be required and it is obviously much slower. Since 1.0.3 it also supports OpenCV for more advanced features like tracking, shape detection, etc.

Product Versions
.NET net5.0 net5.0-windows net6.0 net6.0-android net6.0-ios net6.0-maccatalyst net6.0-macos net6.0-tvos net6.0-windows
Compatible target framework(s)
Additional computed target framework(s)
Learn more about Target Frameworks and .NET Standard.

NuGet packages

This package is not used by any NuGet packages.

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
11.6.2.1 694 4/11/2022
11.6.2 273 3/15/2022
11.6.1 277 2/25/2022
11.6.0 296 1/24/2022
11.4.2 424 10/11/2021
11.1.1 708 1/15/2021
11.1.0 261 1/12/2021
1.0.7 378 11/4/2020
1.0.6 402 4/17/2020
1.0.5 305 4/17/2020
1.0.4 268 4/17/2020
1.0.3 410 1/9/2020
1.0.0 310 11/19/2019