DotNetCore.ApiTemplate.CSharp 1.0.2

dotnet new --install DotNetCore.ApiTemplate.CSharp::1.0.2
This package contains a .NET Core Template Package you can call from the shell/command line.

安装

dotnet new --install DotNetCore.ApiTemplate.CSharp::1.0.2

卸载

dotnet new -u DotNetCore.ApiTemplate.CSharp

帮助

dotnet new dncat --help

DotNetCoreApiTemplate (C#)
作者: 欧俊
选项:
  -ha|--hangfire  是否使用hangfire
                  bool - Required

  -r|--rabbitmq   是否使用RabbitMQ,使用 RabbitMQ.EventBus.AspNetCore包
                  bool - Required

  -re|--redis     是否使用DistributedRedisCache
                  bool - Required

  -p|--pg         是否使用Postgresql
                  bool - Optional
                  默认: true

  -e|--es         是否使用ElasticSearch
                  bool - Required

使用pg,rabbitmq,redis

dotnet new dncat -n Core.New.Service -ha false -r true -re true -e false -p true

使用pg,rabbitmq,redis,hangfire

dotnet new dncat -n Core.New.Service -ha true -r true -re true -e false -p true

使用pg,rabbitmq,redis,es

dotnet new dncat -n Core.New.Service -ha false -r true -re true -e true -p true

使用rabbitmq,es

dotnet new dncat -n Core.New.Service -ha false -r true -re false -e true -p false

NuGet packages

This package is not used by any NuGet packages.

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
1.0.2 758 8/17/2021