CS-Script.RoslynProvider 3.30.0

There is a newer version of this package available.
See the version list below for details.
dotnet add package CS-Script.RoslynProvider --version 3.30.0
NuGet\Install-Package CS-Script.RoslynProvider -Version 3.30.0
This command is intended to be used within the Package Manager Console in Visual Studio, as it uses the NuGet module's version of Install-Package.
<PackageReference Include="CS-Script.RoslynProvider" Version="3.30.0" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add CS-Script.RoslynProvider --version 3.30.0
#r "nuget: CS-Script.RoslynProvider, 3.30.0"
#r directive can be used in F# Interactive and Polyglot Notebooks. Copy this into the interactive tool or source code of the script to reference the package.
// Install CS-Script.RoslynProvider as a Cake Addin
#addin nuget:?package=CS-Script.RoslynProvider&version=3.30.0

// Install CS-Script.RoslynProvider as a Cake Tool
#tool nuget:?package=CS-Script.RoslynProvider&version=3.30.0

The CodeDom provider for CS-Script Class Library that targets Roslyn.

Product Compatible and additional computed target framework versions.
.NET Framework net46 is compatible.  net461 was computed.  net462 was computed.  net463 was computed.  net47 was computed.  net471 was computed.  net472 was computed.  net48 was computed.  net481 was computed. 
Compatible target framework(s)
Included target framework(s) (in package)
Learn more about Target Frameworks and .NET Standard.

NuGet packages

This package is not used by any NuGet packages.

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
3.30.5-pre 337 12/20/2020
3.30.3 2,837 5/30/2020
3.30.0 751 10/14/2019
3.29.0 672 5/22/2019
3.28.7 1,351 9/2/2018
3.28.4 1,194 4/28/2018
3.28.2 2,289 3/15/2018
3.28.0.1 2,003 2/5/2018
3.28.0 879 2/4/2018
3.27.0 987 7/19/2017
3.26.2 1,303 6/30/2017

- Issue #25: Feature request to support conditional directives
- Issue #160: Compatibility with old script syntax
- Issue #161: Assembly is (tried to be) loaded from GAC instead of local dir
- Triggered by issue #172: CsvHelper loads the wrong ValueTuple version in CSScript?
- Issue #173: C# script installation on Window10 / WSL linux does not work
- Added support for _gitignore_ syntax in `//css_` directives (e.g. `//css_ref .\**\Release\*.dll`)
- Added processing precompilers output for `-proj` option
- Added debugVS2019.cs
- Improved version info output
- Fixed all urls pointing to the old web hosting
- Added support for PreferredRuntime of the dependency packages when resolving them.
- Added VB samples for NuGet package (partial solution for #155)
- Added syntax help output info