softaware.CQS.DependencyInjection 1.0.2

.NET Standard 2.1
Suggested Alternatives

softaware.CQS.DependencyInjection 1.0.3

Additional Details

Use latest version to support using decorators with generic type constraints.

There is a newer version of this package available.
See the version list below for details.
dotnet add package softaware.CQS.DependencyInjection --version 1.0.2
NuGet\Install-Package softaware.CQS.DependencyInjection -Version 1.0.2
This command is intended to be used within the Package Manager Console in Visual Studio, as it uses the NuGet module's version of Install-Package.
<PackageReference Include="softaware.CQS.DependencyInjection" Version="1.0.2" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add softaware.CQS.DependencyInjection --version 1.0.2
#r "nuget: softaware.CQS.DependencyInjection, 1.0.2"
#r directive can be used in F# Interactive and Polyglot Notebooks. Copy this into the interactive tool or source code of the script to reference the package.
// Install softaware.CQS.DependencyInjection as a Cake Addin
#addin nuget:?package=softaware.CQS.DependencyInjection&version=1.0.2

// Install softaware.CQS.DependencyInjection as a Cake Tool
#tool nuget:?package=softaware.CQS.DependencyInjection&version=1.0.2

softaware CQS dependency injection builder extensions Microsoft.Extensions.DependencyInjection framework.

Product Compatible and additional computed target framework versions.
.NET net5.0 was computed.  net5.0-windows was computed.  net6.0 was computed.  net6.0-android was computed.  net6.0-ios was computed.  net6.0-maccatalyst was computed.  net6.0-macos was computed.  net6.0-tvos was computed.  net6.0-windows was computed.  net7.0 was computed.  net7.0-android was computed.  net7.0-ios was computed.  net7.0-maccatalyst was computed.  net7.0-macos was computed.  net7.0-tvos was computed.  net7.0-windows was computed.  net8.0 was computed.  net8.0-android was computed.  net8.0-ios was computed.  net8.0-maccatalyst was computed.  net8.0-macos was computed.  net8.0-tvos was computed.  net8.0-windows was computed. 
.NET Core netcoreapp3.0 was computed.  netcoreapp3.1 was computed. 
.NET Standard netstandard2.1 is compatible. 
MonoAndroid monoandroid was computed. 
MonoMac monomac was computed. 
MonoTouch monotouch was computed. 
Tizen tizen60 was computed. 
Xamarin.iOS xamarinios was computed. 
Xamarin.Mac xamarinmac was computed. 
Xamarin.TVOS xamarintvos was computed. 
Xamarin.WatchOS xamarinwatchos was computed. 
Compatible target framework(s)
Additional computed target framework(s)
Learn more about Target Frameworks and .NET Standard.

NuGet packages (5)

Showing the top 5 NuGet packages that depend on softaware.CQS.DependencyInjection:

Package Downloads
softaware.CQS.Decorators.Validation.DependencyInjection

Dependency injection builder extensions for the softaware.CQS.Decorators.Validation package.

softaware.CQS.Decorators.Transaction.DependencyInjection

Dependency injection builder extensions for the softaware.CQS.Decorators.Transaction package.

softaware.CQS.Decorators.FluentValidation.DependencyInjection

Dependency injection builder extensions for the softaware.CQS.Decorators.FluentValidation package.

softaware.CQS.Decorators.ApplicationInsights.DependencyInjection

Dependency injection builder extensions for the softaware.CQS.Decorators.ApplicationInsights package.

softaware.CQS.Decorators.UsageAware.DependencyInjection

Dependency injection builder extensions for the softaware.CQS.Decorators.UsageAware package.

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
4.0.1 2,719 3/9/2023
4.0.0 7,380 8/22/2022
4.0.0-beta.2 105 8/10/2022
4.0.0-beta.1 98 8/10/2022
4.0.0-beta 202 8/9/2022
1.0.3 958 2/14/2022
1.0.2 662 1/5/2022
1.0.1 4,655 11/16/2021