Rocket.Surgery.Extensions.Testing.Coverlet 5.1.0

.NET Standard 2.0
There is a newer version of this package available.
See the version list below for details.
NuGet\Install-Package Rocket.Surgery.Extensions.Testing.Coverlet -Version 5.1.0
This command is intended to be used within the Package Manager Console in Visual Studio, as it uses the NuGet module's version of Install-Package.
dotnet add package Rocket.Surgery.Extensions.Testing.Coverlet --version 5.1.0
<PackageReference Include="Rocket.Surgery.Extensions.Testing.Coverlet" Version="5.1.0" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add Rocket.Surgery.Extensions.Testing.Coverlet --version 5.1.0
#r "nuget: Rocket.Surgery.Extensions.Testing.Coverlet, 5.1.0"
#r directive can be used in F# Interactive, C# scripting and .NET Interactive. Copy this into the interactive tool or source code of the script to reference the package.
// Install Rocket.Surgery.Extensions.Testing.Coverlet as a Cake Addin
#addin nuget:?package=Rocket.Surgery.Extensions.Testing.Coverlet&version=5.1.0

// Install Rocket.Surgery.Extensions.Testing.Coverlet as a Cake Tool
#tool nuget:?package=Rocket.Surgery.Extensions.Testing.Coverlet&version=5.1.0

Package Description

Product Versions
.NET net5.0 net5.0-windows net6.0 net6.0-android net6.0-ios net6.0-maccatalyst net6.0-macos net6.0-tvos net6.0-windows
.NET Core netcoreapp2.0 netcoreapp2.1 netcoreapp2.2 netcoreapp3.0 netcoreapp3.1
.NET Standard netstandard2.0 netstandard2.1
.NET Framework net461 net462 net463 net47 net471 net472 net48
MonoAndroid monoandroid
MonoMac monomac
MonoTouch monotouch
Tizen tizen40 tizen60
Xamarin.iOS xamarinios
Xamarin.Mac xamarinmac
Xamarin.TVOS xamarintvos
Xamarin.WatchOS xamarinwatchos
Compatible target framework(s)
Additional computed target framework(s)
Learn more about Target Frameworks and .NET Standard.

NuGet packages (4)

Showing the top 4 NuGet packages that depend on Rocket.Surgery.Extensions.Testing.Coverlet:

Package Downloads
Rocket.Surgery.Extensions.Testing

Package Description

Rocket.Surgery.Extensions.Testing.FakeItEasy

Package Description

Rocket.Surgery.Extensions.Testing.Moq

Package Description

Rocket.Surgery.Extensions.Testing.NSubstitute

Package Description

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
7.1.2 1,284 6/30/2022
7.1.1 198 6/29/2022
7.1.0 275 6/4/2022
7.0.2 357 5/10/2022
7.0.1 319 4/14/2022
6.1.1 352 2/19/2022
6.1.0 901 2/10/2022
6.0.4 775 1/23/2022
6.0.3 2,041 10/24/2021
6.0.2 2,162 10/14/2021
6.0.1 11,401 12/9/2020
6.0.0 6,000 11/11/2020
5.3.0 15,413 8/20/2020
5.2.5 8,787 7/18/2020
5.2.4 505 7/18/2020
5.2.3 1,327 7/13/2020
5.2.2 750 7/11/2020
5.2.1 2,727 7/4/2020
5.2.0 2,794 6/24/2020
5.1.1 8,944 4/3/2020
5.1.0 1,338 3/31/2020
5.0.0 2,379 2/23/2020
4.1.1 964 2/22/2020
4.1.0 572 2/22/2020
4.0.1 638 2/11/2020
4.0.0 589 2/11/2020
3.4.0 3,674 1/17/2020
3.3.0 3,283 12/16/2019
3.2.2 3,239 11/12/2019
3.2.1 851 11/10/2019
3.2.0 645 11/9/2019
3.1.0 609 11/9/2019
3.0.1 1,971 10/27/2019
3.0.0 742 10/24/2019
2.2.1 1,258 10/17/2019
2.2.0 1,024 10/15/2019
2.1.2 2,101 9/28/2019
2.1.0 1,333 9/27/2019
2.0.2 804 9/25/2019
2.0.1 749 9/24/2019
2.0.0 1,717 9/22/2019

## v5.1.0


As part of this release we had [14 commits](https://github.com/RocketSurgeonsGuild/Testing/compare/v5.0.0...v5.1.0) which resulted in [1 issue](https://github.com/RocketSurgeonsGuild/Testing/milestone/39?closed=1) being closed.


__ mysterious__

- [__#134__](https://github.com/RocketSurgeonsGuild/Testing/pull/134) Ensure that optional parameters are not auto-mocked / faked




## Changes:

* Merge pull request #147 from RocketSurgeonsGuild/dependabot/nuget/master/GitVersion.Tool-5.2.4
* Bump GitVersion.Tool from 5.1.3 to 5.2.4
* Merge pull request #143 from RocketSurgeonsGuild/dependabot/nuget/master/ReportGenerator-4.5.2
* Merge pull request #148 from RocketSurgeonsGuild/dependabot/nuget/master/FluentAssertions-5.10.3
* Bump ReportGenerator from 4.5.0 to 4.5.2
* Merge pull request #152 from RocketSurgeonsGuild/dependabot/nuget/master/DryIoc.dll-4.1.3
* Merge pull request #151 from RocketSurgeonsGuild/dependabot/nuget/master/Nuke.Common-0.24.7
* Bump DryIoc.dll from 4.1.1 to 4.1.3
* Bump Nuke.Common from 0.24.4 to 0.24.7
* Bump FluentAssertions from 5.10.2 to 5.10.3
<details><summary><b>See More</b></summary>

* Updated dependencies
* Merge pull request #134 from RocketSurgeonsGuild/fix/optional-parameters
* Moved to using extension methods for the common DryIoc bits
* Ensure that optional parameters are not auto-mocked / faked +semver:minor

This list of changes was [auto generated](https://rocketsurgeonsguild.visualstudio.com/Libraries/_build/results?buildId=10548&view=logs).</details>