Pygmalions.Prism.Framework 1.0.0

There is a newer version of this package available.
See the version list below for details.
dotnet add package Pygmalions.Prism.Framework --version 1.0.0                
NuGet\Install-Package Pygmalions.Prism.Framework -Version 1.0.0                
This command is intended to be used within the Package Manager Console in Visual Studio, as it uses the NuGet module's version of Install-Package.
<PackageReference Include="Pygmalions.Prism.Framework" Version="1.0.0" />                
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add Pygmalions.Prism.Framework --version 1.0.0                
#r "nuget: Pygmalions.Prism.Framework, 1.0.0"                
#r directive can be used in F# Interactive and Polyglot Notebooks. Copy this into the interactive tool or source code of the script to reference the package.
// Install Pygmalions.Prism.Framework as a Cake Addin
#addin nuget:?package=Pygmalions.Prism.Framework&version=1.0.0

// Install Pygmalions.Prism.Framework as a Cake Tool
#tool nuget:?package=Pygmalions.Prism.Framework&version=1.0.0                

Prism Framework

This framework provides a generator to generate proxy class which can override non-final virtual methods of base classes in run-time.

The generator is implemented with dynamic IL weaving via System.Reflection.Emit library. It is designed in plugin model, which allows users to easily extend its function.

Product Compatible and additional computed target framework versions.
.NET net6.0 is compatible.  net6.0-android was computed.  net6.0-ios was computed.  net6.0-maccatalyst was computed.  net6.0-macos was computed.  net6.0-tvos was computed.  net6.0-windows was computed.  net7.0 was computed.  net7.0-android was computed.  net7.0-ios was computed.  net7.0-maccatalyst was computed.  net7.0-macos was computed.  net7.0-tvos was computed.  net7.0-windows was computed.  net8.0 was computed.  net8.0-android was computed.  net8.0-browser was computed.  net8.0-ios was computed.  net8.0-maccatalyst was computed.  net8.0-macos was computed.  net8.0-tvos was computed.  net8.0-windows was computed. 
Compatible target framework(s)
Included target framework(s) (in package)
Learn more about Target Frameworks and .NET Standard.
  • net6.0

    • No dependencies.

NuGet packages (3)

Showing the top 3 NuGet packages that depend on Pygmalions.Prism.Framework:

Package Downloads
Pygmalions.Prism.Injecting

This plugin provides a mechanism to do proactive dependency injection, which means the object to inject proactively get the injection content from the container.

Pygmalions.Prism.Remoting

This plugin provides a mechnaism to encode and decode invocation contexts to support RPC.

Pygmalions.Prism.Decorating

This plugin provides a mechanism to modify the behavior of functions in run-time.

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
1.3.0 668 12/7/2022
1.2.4 543 12/7/2022
1.2.3 602 12/7/2022
1.2.2 632 12/4/2022
1.2.1 576 11/24/2022
1.2.0 917 10/31/2022
1.1.0 1,224 10/17/2022
1.0.0 847 8/3/2022