PowerUtils.Net.Primitives 1.2.0

There is a newer version of this package available.
See the version list below for details.
dotnet add package PowerUtils.Net.Primitives --version 1.2.0
NuGet\Install-Package PowerUtils.Net.Primitives -Version 1.2.0
This command is intended to be used within the Package Manager Console in Visual Studio, as it uses the NuGet module's version of Install-Package.
<PackageReference Include="PowerUtils.Net.Primitives" Version="1.2.0" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add PowerUtils.Net.Primitives --version 1.2.0
#r "nuget: PowerUtils.Net.Primitives, 1.2.0"
#r directive can be used in F# Interactive and Polyglot Notebooks. Copy this into the interactive tool or source code of the script to reference the package.
// Install PowerUtils.Net.Primitives as a Cake Addin
#addin nuget:?package=PowerUtils.Net.Primitives&version=1.2.0

// Install PowerUtils.Net.Primitives as a Cake Tool
#tool nuget:?package=PowerUtils.Net.Primitives&version=1.2.0

Provides additional types and constants for network-based libraries.

Product Compatible and additional computed target framework versions.
.NET net5.0 is compatible.  net5.0-windows was computed.  net6.0 is compatible.  net6.0-android was computed.  net6.0-ios was computed.  net6.0-maccatalyst was computed.  net6.0-macos was computed.  net6.0-tvos was computed.  net6.0-windows was computed.  net7.0 was computed.  net7.0-android was computed.  net7.0-ios was computed.  net7.0-maccatalyst was computed.  net7.0-macos was computed.  net7.0-tvos was computed.  net7.0-windows was computed.  net8.0 was computed.  net8.0-android was computed.  net8.0-browser was computed.  net8.0-ios was computed.  net8.0-maccatalyst was computed.  net8.0-macos was computed.  net8.0-tvos was computed.  net8.0-windows was computed. 
.NET Core netcoreapp3.1 is compatible. 
Compatible target framework(s)
Included target framework(s) (in package)
Learn more about Target Frameworks and .NET Standard.
  • .NETCoreApp 3.1

    • No dependencies.
  • net5.0

    • No dependencies.
  • net6.0

    • No dependencies.

NuGet packages (1)

Showing the top 1 NuGet packages that depend on PowerUtils.Net.Primitives:

Package Downloads
PowerUtils.GuardClauses.Validations

Helpers, extensions and utilities to work with guard clause

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
1.4.0 404 6/4/2023
1.3.0 1,251 8/21/2022
1.2.0 5,517 3/2/2022
1.1.1 414 2/25/2022
1.1.0 386 2/25/2022
1.0.0 1,622 11/21/2021

- Added new constants for status codes;
     - Added utils `int.GetStatusCodeLinkOrDefault()`;
     - Fixed link for status code Unprocessable Entity 422;