NUnit3.DotNetNew.Template 1.9.0

dotnet new --install NUnit3.DotNetNew.Template::1.9.0
This package contains a .NET Core Template Package you can call from the shell/command line.
  • Add .NET 6.0 and make the default
  • update NUnit3TestAdapter to v4.2.1 on .NET Core 2.1+
  • update NUnit to v3.13.3
  • update Microsoft.NET.Test.Sdk to v7.1.0 on .NET 6.0+
  • Removed EOL .NET Core versions

This package has no dependencies.

NuGet packages

This package is not used by any NuGet packages.

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
1.9.0 8,425 3/31/2022
1.8.1 115,062 4/15/2020
1.8.0 13,066 3/27/2020
1.7.2 124,975 3/18/2020
1.7.1 80,736 11/12/2019
1.7.0 22,406 10/25/2019
1.6.5 202,130 11/12/2019
1.6.4 18,718 10/25/2019
1.6.3 88,885 8/6/2019
1.6.2 1,703 4/9/2019
1.6.1 206,137 1/11/2019
1.6.0 238,089 11/20/2018
1.5.3 399,657 10/24/2018
1.5.2 2,935 9/12/2018
1.5.1 35,954 6/7/2018
1.5.0 803 6/5/2018
1.4.0 5,638 3/20/2018
1.3.0 3,486 11/14/2017
1.2.0 795 11/8/2017
1.1.0 1,219 7/24/2017
1.0.1 889 5/31/2017
1.0.0 789 5/30/2017

- NUnit v3.12.0
- NUnit3TestAdapter v3.16.1
- Microsoft.NET.Test.Sdk v16.5.0
- add new `--framework` supported parameters: net6.0
- update all project templates to default to net6.0. Other frameworks can still be selected with the `--framework` command line option.