Footloose.Amqp 2.0.0

.NET Framework 4.0
There is a newer prerelease version of this package available.
See the version list below for details.
Install-Package Footloose.Amqp -Version 2.0.0
dotnet add package Footloose.Amqp --version 2.0.0
<PackageReference Include="Footloose.Amqp" Version="2.0.0" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add Footloose.Amqp --version 2.0.0
The NuGet Team does not provide support for this client. Please contact its maintainers for support.
#r "nuget: Footloose.Amqp, 2.0.0"
#r directive can be used in F# Interactive, C# scripting and .NET Interactive. Copy this into the interactive tool or source code of the script to reference the package.
// Install Footloose.Amqp as a Cake Addin
#addin nuget:?package=Footloose.Amqp&version=2.0.0

// Install Footloose.Amqp as a Cake Tool
#tool nuget:?package=Footloose.Amqp&version=2.0.0
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

Footloose is a fast and scalable asynchronous distributed computing and service library that was designed to be fast, secure, simple to use, unobtrusive and without the need of client side code generation or proxy classes.

     It was developed to connect or build distributed applications on the .NET/Mono platform with enterprise features like load-balancing, clustering, encryption, service discovery and single-sign on.


     FEATURES

     - easy to use, only a few lines of code to start with Footloose
     - Unobtrusive, no Attributes like [OperationContract] and no base class required
     - No Code-Gen / Client Proxy Classes - keep your code clean
     - several TransportChannels: XMPP, IPC, AMQP
     - Security, Encryption and Compression (depends on Transport Channel)
     - Endpoint Capabilities and Service Discovery
     - Sharing Presence Information (Online, Offline, temp. unavailable, etc. incl. priority and reason)
     - Single-SignOn
     - bi-directional communication, no polling
     - Model driven - use your strongly-typed DTOs/POCOs


     LICENSE

     In order to use Footloose you need a valid license. You can request a free trial license
     at http://www.footloose-project.de/request-trial-license/


     FURTHER INFORMATION

     The latest release and documentation can be found on
     the Footloose project website:

     http://www.footloose-project.de/

Product Versions
.NET Framework net40 net403 net45 net451 net452 net46 net461 net462 net463 net47 net471 net472 net48
Compatible target framework(s)
Additional computed target framework(s)
Learn more about Target Frameworks and .NET Standard.

NuGet packages

This package is not used by any NuGet packages.

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
3.0.0-beta4 950 1/10/2013
3.0.0-beta3 841 1/10/2013
3.0.0-beta2 830 1/10/2013
3.0.0-beta1 927 12/19/2012
3.0.0-alpha4 825 12/14/2012
3.0.0-alpha3 1,236 12/11/2012
3.0.0-alpha2 967 11/29/2012
3.0.0-alpha1 1,150 11/28/2012
2.1.0-alpha1 1,040 11/22/2012
2.0.0 1,617 11/17/2012
2.0.0-rc1 1,071 11/15/2012
2.0.0-beta2 1,057 11/14/2012
2.0.0-beta1 966 10/26/2012
2.0.0-alpha3 938 10/20/2012
2.0.0-alpha2 1,003 10/5/2012
2.0.0-alpha1 933 10/5/2012
1.0.0 1,109 8/7/2012