EntityFrameworkCore.Exceptions.PostgreSQL 6.0.3

There is a newer version of this package available.
See the version list below for details.
dotnet add package EntityFrameworkCore.Exceptions.PostgreSQL --version 6.0.3
NuGet\Install-Package EntityFrameworkCore.Exceptions.PostgreSQL -Version 6.0.3
This command is intended to be used within the Package Manager Console in Visual Studio, as it uses the NuGet module's version of Install-Package.
<PackageReference Include="EntityFrameworkCore.Exceptions.PostgreSQL" Version="6.0.3" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add EntityFrameworkCore.Exceptions.PostgreSQL --version 6.0.3
#r "nuget: EntityFrameworkCore.Exceptions.PostgreSQL, 6.0.3"
#r directive can be used in F# Interactive and Polyglot Notebooks. Copy this into the interactive tool or source code of the script to reference the package.
// Install EntityFrameworkCore.Exceptions.PostgreSQL as a Cake Addin
#addin nuget:?package=EntityFrameworkCore.Exceptions.PostgreSQL&version=6.0.3

// Install EntityFrameworkCore.Exceptions.PostgreSQL as a Cake Tool
#tool nuget:?package=EntityFrameworkCore.Exceptions.PostgreSQL&version=6.0.3

Handle database errors easily when working with Entity Framework Core. Catch specific exceptions such as UniqueConstraintException, CannotInsertNullException, MaxLengthExceededException, NumericOverflowException or ReferenceConstraintException instead of generic DbUpdateException

Product Compatible and additional computed target framework versions.
.NET net6.0 is compatible.  net6.0-android was computed.  net6.0-ios was computed.  net6.0-maccatalyst was computed.  net6.0-macos was computed.  net6.0-tvos was computed.  net6.0-windows was computed.  net7.0 was computed.  net7.0-android was computed.  net7.0-ios was computed.  net7.0-maccatalyst was computed.  net7.0-macos was computed.  net7.0-tvos was computed.  net7.0-windows was computed.  net8.0 was computed.  net8.0-android was computed.  net8.0-browser was computed.  net8.0-ios was computed.  net8.0-maccatalyst was computed.  net8.0-macos was computed.  net8.0-tvos was computed.  net8.0-windows was computed. 
Compatible target framework(s)
Included target framework(s) (in package)
Learn more about Target Frameworks and .NET Standard.

NuGet packages (5)

Showing the top 5 NuGet packages that depend on EntityFrameworkCore.Exceptions.PostgreSQL:

Package Downloads
Newguys.Sport

Package Description

AuthPermissions.AspNetCore

Provides extra authorization and multi-tenant features to an ASP.NET Core application.

MarketingBox.Sdk.Postgres

Package Description

Newguys.GameProviders.Common

Package Description

Upper.Core

Package Description

GitHub repositories (3)

Showing the top 3 popular GitHub repositories that depend on EntityFrameworkCore.Exceptions.PostgreSQL:

Repository Stars
JonPSmith/AuthPermissions.AspNetCore
This library provides extra authorization and multi-tenant features to an ASP.NET Core application.
yanpitangui/dotnet-api-boilerplate
A Dotnet 8.0 WebApi template project. MediatR, Swagger, Mapper, Serilog and more implemented.
Valour-Software/Valour
Valour is bringing communities into the future with unique features, blazing performance, and respect for users.
Version Downloads Last updated
8.1.2 64,581 3/22/2024
8.1.1 1,569 3/21/2024
8.1.0 5,016 3/16/2024
8.0.0 100,282 12/11/2023
6.0.3 889,575 3/16/2022
3.1.4 131,520 2/12/2021
3.1.1 62,197 1/22/2020
1.0.1 18,050 6/11/2019
1.0.0 1,668 1/23/2019
0.1.0-beta 570 12/5/2018

Update to .NET 6 and EF Core 6.0