BundleTransformer.SassAndScss 1.13.0-preview2 Prefix Reserved

This is a prerelease version of BundleTransformer.SassAndScss.
Install-Package BundleTransformer.SassAndScss -Version 1.13.0-preview2
dotnet add package BundleTransformer.SassAndScss --version 1.13.0-preview2
<PackageReference Include="BundleTransformer.SassAndScss" Version="1.13.0-preview2" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add BundleTransformer.SassAndScss --version 1.13.0-preview2
The NuGet Team does not provide support for this client. Please contact its maintainers for support.
#r "nuget: BundleTransformer.SassAndScss, 1.13.0-preview2"
#r directive can be used in F# Interactive, C# scripting and .NET Interactive. Copy this into the interactive tool or source code of the script to reference the package.
// Install BundleTransformer.SassAndScss as a Cake Addin
#addin nuget:?package=BundleTransformer.SassAndScss&version=1.13.0-preview2&prerelease

// Install BundleTransformer.SassAndScss as a Cake Tool
#tool nuget:?package=BundleTransformer.SassAndScss&version=1.13.0-preview2&prerelease
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

BundleTransformer.SassAndScss contains one translator-adapter - `SassAndScssTranslator`. This adapter makes translation of Sass and SCSS code to CSS code by using the Dart Sass Host for .NET (https://github.com/Taritsyn/DartSassHost) version 1.0.0 Preview 3 (supports the Dart Sass (https://github.com/sass/dart-sass) version 1.36.0). Also contains the `SassAndScssAssetHandler` debugging HTTP handler, which is responsible for text output of translated Sass or SCSS asset.

As a JS engine is used the JavaScript Engine Switcher library (https://github.com/Taritsyn/JavaScriptEngineSwitcher). For correct working of this module, you need to install one of the following NuGet packages: JavaScriptEngineSwitcher.Msie (only in the Chakra JsRT modes), JavaScriptEngineSwitcher.V8 or JavaScriptEngineSwitcher.ChakraCore.

NuGet packages (1)

Showing the top 1 NuGet packages that depend on BundleTransformer.SassAndScss:

Package Downloads
ModernSkins

Auto bundling and minification for ASP.NET MVC applications.

GitHub repositories (1)

Showing the top 1 popular GitHub repositories that depend on BundleTransformer.SassAndScss:

Repository Stars
smartstore/SmartStoreNET
Open Source ASP.NET MVC Enterprise eCommerce Shopping Cart Solution
Version Downloads Last updated
1.13.0-preview2 146 7/29/2021
1.13.0-preview1 118 7/24/2021
1.12.36 4,607 5/23/2021
1.12.22 11,832 10/9/2020
1.12.12 12,367 5/14/2020
1.12.11 2,102 4/15/2020
1.12.6 23,583 11/19/2019
1.12.4 7,196 10/8/2019
1.12.1 9,812 8/23/2019
1.10.4 37,018 3/1/2019
1.10.0 32,615 12/26/2018
1.10.0-beta1 459 12/10/2018
1.9.216 2,839 11/19/2018
1.9.202.1 25,955 4/26/2018
1.9.198 3,134 3/22/2018
1.9.197 872 3/14/2018
1.9.195 789 3/7/2018
1.9.188 3,093 2/7/2018
1.9.186 1,229 1/14/2018
1.9.183 57,857 12/11/2017
1.9.179 2,723 10/26/2017
1.9.160 58,928 6/15/2017
1.9.154 17,968 4/7/2017
1.9.153 2,485 3/26/2017
1.9.152 3,608 3/3/2017
1.9.152-beta1 652 3/1/2017
1.9.144 10,042 1/8/2017
1.9.143 908 1/5/2017
1.9.140 3,179 12/23/2016
1.9.138 3,309 12/10/2016
1.9.131 4,770 11/1/2016
1.9.131-beta1 678 10/25/2016
1.9.104 37,523 4/24/2016
1.9.96 5,073 3/21/2016
1.9.95 993 3/20/2016
1.9.92 2,901 3/8/2016
1.9.92-beta2 676 3/3/2016
1.9.92-beta1 677 3/2/2016
1.9.92-alpha2 2,085 1/21/2016
1.9.92-alpha1 718 1/19/2016
1.9.81 13,260 11/11/2015
1.9.81-beta2 691 11/10/2015
1.9.81-beta1 703 11/4/2015
1.9.72 13,207 8/31/2015
1.9.68 3,832 6/24/2015
1.9.64 2,061 5/24/2015
1.9.52 3,157 3/30/2015
1.9.49 2,280 2/27/2015
1.9.48 1,081 2/23/2015
1.9.47 891 2/22/2015
1.9.47-Beta1 697 2/14/2015
1.9.34 14,089 12/19/2014
1.9.25 2,417 10/14/2014
1.9.13 2,984 8/7/2014
1.9.11 2,338 7/28/2014
1.9.10 1,300 7/15/2014
1.9.7 1,073 7/7/2014
1.9.4 961 6/29/2014
1.9.1 1,002 6/25/2014
1.9.0 1,014 6/23/2014
1.9.0-Beta3 735 6/21/2014
1.9.0-Beta2 745 6/16/2014
1.9.0-Beta1 766 6/13/2014
1.8.32 22,185 5/14/2014
1.8.30 1,551 4/28/2014
1.8.29 1,676 4/10/2014
1.8.23 3,008 2/21/2014
1.8.20 1,060 2/4/2014
1.8.18 1,240 1/22/2014
1.8.14 1,523 12/3/2013
1.8.14-Beta1 768 11/28/2013
1.8.12 991 11/24/2013
1.8.11 1,143 11/7/2013
1.8.10 960 11/4/2013
1.8.9 1,086 10/25/2013
1.8.8 921 10/24/2013
1.8.7 1,147 10/16/2013
1.8.3 2,128 9/12/2013
1.8.0 1,236 9/5/2013
1.7.27 1,047 8/26/2013
1.7.21 1,312 8/4/2013
1.7.16 1,264 7/11/2013
1.7.15-Beta1 908 6/18/2013
1.7.13-Beta1 866 6/14/2013
1.7.9-Beta1 890 5/27/2013
1.7.7-Beta1 865 5/3/2013
1.7.1-Beta1 936 3/22/2013
1.7.0-Beta1 850 3/19/2013
1.6.31 1,069 6/18/2013
1.6.29 1,038 6/14/2013
1.6.26 1,053 5/28/2013
1.6.25 1,073 5/13/2013
1.6.18 7,213 2/5/2013
1.6.13 1,239 12/4/2012
1.6.11 1,044 11/22/2012
1.6.10 1,001 11/17/2012
1.6.9 1,492 10/29/2012
1.6.8 1,083 10/27/2012
1.6.6 1,210 10/15/2012
1.6.5 1,186 10/11/2012
1.6.1 1,028 9/20/2012
1.6.0 1,018 9/12/2012
1.5.5 1,117 8/29/2012
1.5.0 1,019 8/16/2012
1.4.3-beta3 914 8/1/2012
1.4.2-beta3 894 6/23/2012
1.4.1-beta3 939 6/19/2012
1.4.0-beta2 846 6/6/2012
1.3.0-beta 861 5/16/2012
1.2.1-beta 877 4/8/2012
1.2.0-beta 904 4/3/2012
1.1.0-beta 868 3/29/2012
1.0.0-beta 884 3/25/2012

1. Added support of the Dart Sass version 1.36.0;
2. Now can use the JavaScriptEngineSwitcher.V8 as a JS engine.