TurkishId 3.1.0

.NET Standard 2.1
Install-Package TurkishId -Version 3.1.0
dotnet add package TurkishId --version 3.1.0
<PackageReference Include="TurkishId" Version="3.1.0" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add TurkishId --version 3.1.0
The NuGet Team does not provide support for this client. Please contact its maintainers for support.
#r "nuget: TurkishId, 3.1.0"
#r directive can be used in F# Interactive, C# scripting and .NET Interactive. Copy this into the interactive tool or source code of the script to reference the package.
// Install TurkishId as a Cake Addin
#addin nuget:?package=TurkishId&version=3.1.0

// Install TurkishId as a Cake Tool
#tool nuget:?package=TurkishId&version=3.1.0
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

Turkish ID Number Validation Library

Product Versions
.NET net5.0 net5.0-windows net6.0 net6.0-android net6.0-ios net6.0-maccatalyst net6.0-macos net6.0-tvos net6.0-windows
.NET Core netcoreapp3.0 netcoreapp3.1
.NET Standard netstandard2.1
MonoAndroid monoandroid
MonoMac monomac
MonoTouch monotouch
Tizen tizen60
Xamarin.iOS xamarinios
Xamarin.Mac xamarinmac
Xamarin.TVOS xamarintvos
Xamarin.WatchOS xamarinwatchos
Compatible target framework(s)
Additional computed target framework(s)
Learn more about Target Frameworks and .NET Standard.

NuGet packages (1)

Showing the top 1 NuGet packages that depend on TurkishId:

Package Downloads
TurkishId.ModelBinder

Turkish ID Number Model Binding Library

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
3.1.0 72 4/10/2022
3.0.1 468 12/16/2020
3.0.0 224 12/14/2020
2.2.0 367 11/3/2019
2.1.1 550 12/4/2018
2.1.0 758 7/31/2017
1.2.5984.40030 1,005 5/21/2016
1.1.5813.32782 1,390 12/2/2015
1.0.5432.39496 1,475 11/15/2014
1.0.5432.36431 1,382 11/15/2014

# New features
- Add ReadOnlyChar<span> variant to IsValid()
- Target `netstandard2.1` instead of `net5.0` to broaden support.

# Improvements
- Remove unsafe code.
- Upgrade dependencies