System.Runtime.InteropServices.WindowsRuntime 4.3.0 Prefix Reserved

Requires NuGet 2.12 or higher.

Install-Package System.Runtime.InteropServices.WindowsRuntime -Version 4.3.0
dotnet add package System.Runtime.InteropServices.WindowsRuntime --version 4.3.0
<PackageReference Include="System.Runtime.InteropServices.WindowsRuntime" Version="4.3.0" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add System.Runtime.InteropServices.WindowsRuntime --version 4.3.0
The NuGet Team does not provide support for this client. Please contact its maintainers for support.
#r "nuget: System.Runtime.InteropServices.WindowsRuntime, 4.3.0"
#r directive can be used in F# Interactive, C# scripting and .NET Interactive. Copy this into the interactive tool or source code of the script to reference the package.
// Install System.Runtime.InteropServices.WindowsRuntime as a Cake Addin
#addin nuget:?package=System.Runtime.InteropServices.WindowsRuntime&version=4.3.0

// Install System.Runtime.InteropServices.WindowsRuntime as a Cake Tool
#tool nuget:?package=System.Runtime.InteropServices.WindowsRuntime&version=4.3.0
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

Provides classes that support interoperation between managed code and the Windows Runtime, and that enable the creation of Windows Runtime types with managed code.

Commonly Used Types:
System.Runtime.InteropServices.WindowsRuntime.WindowsRuntimeMarshal
System.Runtime.InteropServices.WindowsRuntime.ReadOnlyArrayAttribute
System.Runtime.InteropServices.WindowsRuntime.WriteOnlyArrayAttribute
System.Runtime.InteropServices.WindowsRuntime.ReturnValueNameAttribute

When using NuGet 3.x this package requires at least version 3.4.

  • .NETCore 5.0

  • .NETFramework 4.5

    • No dependencies.
  • .NETStandard 1.0

  • MonoAndroid 1.0

    • No dependencies.
  • MonoTouch 1.0

    • No dependencies.
  • Portable Class Library (.NETFramework 4.5, Windows 8.0, WindowsPhone 8.0, WindowsPhoneApp 8.1)

    • No dependencies.
  • Windows 8.0

    • No dependencies.
  • WindowsPhone 8.0

    • No dependencies.
  • WindowsPhoneApp 8.1

    • No dependencies.
  • Xamarin.iOS 1.0

    • No dependencies.
  • Xamarin.Mac 2.0

    • No dependencies.
  • Xamarin.TVOS 1.0

    • No dependencies.
  • Xamarin.WatchOS 1.0

    • No dependencies.

NuGet packages (42)

Showing the top 5 NuGet packages that depend on System.Runtime.InteropServices.WindowsRuntime:

Package Downloads
System.Net.NetworkInformation

Provides access to network traffic data, network address information, and notification of address changes for the local computer. Commonly Used Types: System.Net.NetworkInformation.NetworkInterface System.Net.NetworkInformation.NetworkInformationException System.Net.NetworkInformation.NetworkAddressChangedEventHandler System.Net.NetworkInformation.NetworkInterfaceType System.Net.NetworkInformation.OperationalStatus System.Net.NetworkInformation.IPGlobalProperties System.Net.NetworkInformation.UnicastIPAddressInformation System.Net.NetworkInformation.UnicastIPAddressInformationCollection System.Net.NetworkInformation.PhysicalAddress System.Net.NetworkInformation.TcpConnectionInformation When using NuGet 3.x this package requires at least version 3.4.

System.Net.WebSockets.Client

Provides the System.Net.WebSockets.ClientWebSocket class, which implements the client role of the WebSockets protocol (RFC 6455). Commonly Used Types: System.Net.WebSockets.ClientWebSocket When using NuGet 3.x this package requires at least version 3.4.

System.Reactive

Reactive Extensions (Rx) for .NET

Microsoft.NETCore.UniversalWindowsPlatform

Provides a set of packages that can be used when building Universal Windows applications on .NETCore. 1b651b26ca39a8a2b6c090a85b6025565fa46203 When using NuGet 3.x this package requires at least version 3.4.

Microsoft.Windows.SDK.Contracts

The Windows WinRT API Pack enables you to add the latest Windows Runtime APIs support to your .NET Framework 4.6+ and .NET Core 3.0+ libraries and apps.   This package includes all the supported Windows Runtime APIs up to Windows version 22509. If you are targeting earlier platforms, consider only offering functionality available on the detected platform version. For further details, see: https://docs.microsoft.com/en-us/windows/uwp/debug-test-perf/version-adaptive-code Supported platforms: - .NET Framework 4.6+ - .NET Core 3.0+ Requires default package management format set to PackageReference, and NuGet 4.0 or higher.

GitHub repositories (20)

Showing the top 5 popular GitHub repositories that depend on System.Runtime.InteropServices.WindowsRuntime:

Repository Stars
felixse/FluentTerminal
A Terminal Emulator based on UWP and web technologies.
microsoft/ailab
Experience, Learn and Code the latest breakthrough innovations with Microsoft AI
unoplatform/uno
Build Mobile, Desktop and WebAssembly apps with C# and XAML. Today. Open source and professionally supported.
dotnet/reactive
The Reactive Extensions for .NET
Xeroday/Spotify-Ad-Blocker
EZBlocker - A Spotify Ad Blocker for Windows
Version Downloads Last updated
4.3.0 20,521,769 11/15/2016
4.3.0-preview1-24530-04 1,168 10/24/2016
4.0.1 9,040,651 6/27/2016
4.0.1-rc2-24027 2,719 5/16/2016
4.0.1-beta-23516 8,034 11/18/2015
4.0.1-beta-23409 927 10/15/2015
4.0.1-beta-23225 1,756 9/2/2015
4.0.0 1,095,007 7/29/2015
4.0.0-beta-23109 887 7/27/2015
4.0.0-beta-23019 1,259 6/30/2015
4.0.0-beta-22816 1,243 4/24/2015