MetaWear.CSharp.NetStandard 1.0.5

Requires NuGet 4.1 or higher.

Install-Package MetaWear.CSharp.NetStandard -Version 1.0.5
dotnet add package MetaWear.CSharp.NetStandard --version 1.0.5
<PackageReference Include="MetaWear.CSharp.NetStandard" Version="1.0.5" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add MetaWear.CSharp.NetStandard --version 1.0.5
The NuGet Team does not provide support for this client. Please contact its maintainers for support.
#r "nuget: MetaWear.CSharp.NetStandard, 1.0.5"
#r directive can be used in F# Interactive, C# scripting and .NET Interactive. Copy this into the interactive tool or source code of the script to reference the package.
// Install MetaWear.CSharp.NetStandard as a Cake Addin
#addin nuget:?package=MetaWear.CSharp.NetStandard&version=1.0.5

// Install MetaWear.CSharp.NetStandard as a Cake Tool
#tool nuget:?package=MetaWear.CSharp.NetStandard&version=1.0.5
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

Call Application.GetMetaWearBoard with the MAC address of the device you are communicating with. You can then use the SDK features, as outlined in the SDK developers' guide, with the returned IMetaWearBoard object.

using MbientLab.MetaWear.NetStandard;
using System;
using System.Threading.Tasks;

namespace MetaWear.NETCore {
    class Program {
        static void Main(string[] args) {
            MainAsync(args).Wait();
        }

        private static async Task MainAsync(string[] args) {
            var metawear = Application.GetMetaWearBoard(args[1]);
            await metawear.InitializeAsync();
        }
    }
}

NuGet packages

This package is not used by any NuGet packages.

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
1.0.5 1,072 8/4/2018
1.0.1 606 6/26/2018
1.0.0 602 6/21/2018