Ixxat.Vci4.StrongName 4.1.0

.NET 5.0 .NET Core 3.1 .NET Framework 4.0
dotnet add package Ixxat.Vci4.StrongName --version 4.1.0
NuGet\Install-Package Ixxat.Vci4.StrongName -Version 4.1.0
This command is intended to be used within the Package Manager Console in Visual Studio, as it uses the NuGet module's version of Install-Package.
<PackageReference Include="Ixxat.Vci4.StrongName" Version="4.1.0" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add Ixxat.Vci4.StrongName --version 4.1.0
#r "nuget: Ixxat.Vci4.StrongName, 4.1.0"
#r directive can be used in F# Interactive, C# scripting and .NET Interactive. Copy this into the interactive tool or source code of the script to reference the package.
// Install Ixxat.Vci4.StrongName as a Cake Addin
#addin nuget:?package=Ixxat.Vci4.StrongName&version=4.1.0

// Install Ixxat.Vci4.StrongName as a Cake Tool
#tool nuget:?package=Ixxat.Vci4.StrongName&version=4.1.0

VCI4 .NET Wrapper

Introduction

This project contains the source of the VCI4 .NET Wrapper (VCI4 = Virtual Communication Interface Version 4), a component that provides access to the VCI4 C++-API. VCI4 is a driver/application framework to access HMS CAN or LIN interfaces on the Windows OS, for details see https://www.ixxat.com/technical-support/support/windows-driver-software

This package is released as a binary package via NuGet for application developers, for details see https://www.nuget.org/packages/Ixxat.Vci4 There is also a strong named variant which is available from https://www.nuget.org/packages/Ixxat.Vci4.StrongName

Open source

The main purpose to release this component as open source is to give application developers a better insight into the internal workings of the component. As it is mostly a 1:1 wrapper to the underlying VCI4 C++-API there is little encoded functionality, nethertheless access to the source could help clarify unclear behaviour or help detect bugs.

Developers which need more control could alter the component or use it as a template to implement their own device access component on top of the VCI4 C++-API.

For users

See the user documentation in /doc/README.md

For developers

The component is split into three parts:

  • a contract assembly (interface declaration assembly)
  • a loader
  • a managed C++ implementation

The C++ part is compiled twice to x86 and x64 targets. A .NET application only references the loader and the contract assembly and could therefore be kept target agnostic (AnyCPU). The loader checks the platform and loads the corresponding target specific assembly.

To compile the component start a Powershell console and execute

PS> .\build.ps1 -Version=4.1.0

If you want to create a strong named version add the AssemblyKeyFile parameter

PS> .\build.ps1 -Version=4.1.0 -AssemblyKeyFile=mykeyfile.snk

For more information have a look at the build script .\build.ps1 and the msbuild project .\vci4net.prj.

Prerequisites

  • VisualStudio 2022
  • nuget.exe client version 6.3.0
  • Sandcastle Help File Builder version 2021.11.7.0

The VCI4 .NET wrapper sits on top of the VCI4 C++ API so you need the VCI4 driver setup installed.

Source tree overview

\doc           user documentation
\images        package icon
\nuget         files for nuget packaging (manifest files)
\src\contract  Contract assembly
\src\help      Help file builder project
\src\loader    Loader component (API entry point)
\src\impl      Component implementation (mixed assembly source)
\samples       minimal set of samples

Further documentation

See the folder /doc/manual for the user manuals which also gives a system overview.

Installing the VCI4 Setup provides additional manuals for the available VCI4 APIs.

Product Versions
.NET net5.0 net5.0-windows net5.0-windows10.0 net6.0 net6.0-android net6.0-ios net6.0-maccatalyst net6.0-macos net6.0-tvos net6.0-windows net6.0-windows10.0
.NET Core netcoreapp3.1
.NET Framework net40 net403 net45 net451 net452 net46 net461 net462 net463 net47 net471 net472 net48
Compatible target framework(s)
Additional computed target framework(s)
Learn more about Target Frameworks and .NET Standard.
  • .NETCoreApp 3.1

    • No dependencies.
  • .NETFramework 4.0

    • No dependencies.
  • net5.0-windows10.0

    • No dependencies.
  • net6.0-windows10.0

    • No dependencies.

NuGet packages

This package is not used by any NuGet packages.

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
4.1.0 80 11/11/2022
4.0.436 2,587 12/14/2018
4.0.423 646 10/23/2018
4.0.368 2,364 4/6/2017

Resolved issues:
- Loader: use Assembly.Location instead of deprecated Assembly.EscapedCodeBase
- support TargetFrameworks net40, net5.0-windows, net6.0-windows and netcoreapp3.1
- lookup platform specific assembly first in exe path (Assembly.GetEntryAssembly()), then in the path where the loader is located (Assembly.GetCallingAssembly()) (#8111)
- native components: use PlatformToolset v143 and WindowsTargetPlatformVersion 10.0.22000.0
- update to VCI4 core revision 246