FluentMigrator.Runner 3.3.2

The ID prefix of this package has been reserved for one of the owners of this package by NuGet.org. Prefix Reserved
.NET Standard 2.0 .NET Framework 4.6.1

Requires NuGet 3.5 or higher.

dotnet add package FluentMigrator.Runner --version 3.3.2
NuGet\Install-Package FluentMigrator.Runner -Version 3.3.2
This command is intended to be used within the Package Manager Console in Visual Studio, as it uses the NuGet module's version of Install-Package.
<PackageReference Include="FluentMigrator.Runner" Version="3.3.2" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add FluentMigrator.Runner --version 3.3.2
#r "nuget: FluentMigrator.Runner, 3.3.2"
#r directive can be used in F# Interactive, C# scripting and .NET Interactive. Copy this into the interactive tool or source code of the script to reference the package.
// Install FluentMigrator.Runner as a Cake Addin
#addin nuget:?package=FluentMigrator.Runner&version=3.3.2

// Install FluentMigrator.Runner as a Cake Tool
#tool nuget:?package=FluentMigrator.Runner&version=3.3.2

FluentMigrator is a database migration framework for .NET written in C#. The basic idea is that you can create migrations which are simply classes that derive from the Migration base class and have a Migration attribute with a unique version number attached to them. Upon executing FluentMigrator, you tell it which version to migrate to and it will run all necessary migrations in order to bring your database up to that version. In addition to forward migration support, FluentMigrator also supports different ways to execute the migrations along with selective migrations called profiles and executing arbitrary SQL.

Product Versions
.NET net5.0 net5.0-windows net6.0 net6.0-android net6.0-ios net6.0-maccatalyst net6.0-macos net6.0-tvos net6.0-windows net7.0 net7.0-android net7.0-ios net7.0-maccatalyst net7.0-macos net7.0-tvos net7.0-windows
.NET Core netcoreapp2.0 netcoreapp2.1 netcoreapp2.2 netcoreapp3.0 netcoreapp3.1
.NET Standard netstandard2.0 netstandard2.1
.NET Framework net461 net462 net463 net47 net471 net472 net48
MonoAndroid monoandroid
MonoMac monomac
MonoTouch monotouch
Tizen tizen40 tizen60
Xamarin.iOS xamarinios
Xamarin.Mac xamarinmac
Xamarin.TVOS xamarintvos
Xamarin.WatchOS xamarinwatchos
Compatible target framework(s)
Additional computed target framework(s)
Learn more about Target Frameworks and .NET Standard.

NuGet packages (85)

Showing the top 5 NuGet packages that depend on FluentMigrator.Runner:

Package Downloads
Shesha.NHibernate

Package Description

Miru

Package Description

Tofi.Framework.Data

Package Description

HQ

This package contains the full-stack build for HQ.io.

Naos.Database.Migrator

Created on 2018-10-12 15:52

GitHub repositories (13)

Showing the top 5 popular GitHub repositories that depend on FluentMigrator.Runner:

Repository Stars
aspnetboilerplate/aspnetboilerplate
ASP.NET Boilerplate - Web Application Framework
Sonarr/Sonarr
Smart PVR for newsgroup and bittorrent users.
nopSolutions/nopCommerce
ASP.NET Core eCommerce software. nopCommerce is a free and open-source shopping cart.
Lidarr/Lidarr
Looks and smells like Sonarr but made for music.
Prowlarr/Prowlarr
Version Downloads Last updated
3.3.2 1,407,072 1/14/2022
3.3.1 784,224 9/21/2021
3.3.0 152,598 8/26/2021
3.2.17 560,988 6/17/2021
3.2.16 198,355 5/19/2021
3.2.15 810,076 2/19/2021
3.2.14 597 2/19/2021
3.2.11 270,277 1/9/2021
3.2.10 59,227 12/19/2020
3.2.9 1,299,430 8/25/2020
3.2.8 163,944 7/22/2020
3.2.7 449,913 6/8/2020
3.2.6 496,671 4/11/2020
3.2.1 1,999,673 4/16/2019
3.2.0 3,961 4/15/2019
3.1.3 961,574 6/25/2018
3.1.2 3,475 6/21/2018
3.1.1 17,838 6/11/2018
3.1.0 3,170 6/1/2018
3.0.0 49,964 5/7/2018
2.0.7 192,886 4/27/2018
2.0.6 14,992 4/24/2018
2.0.5 2,449 4/23/2018
2.0.4 1,172 4/23/2018
2.0.3 1,454 4/22/2018
2.0.2 84,749 4/17/2018
2.0.1 2,667 4/16/2018
2.0.0 4,002 4/15/2018
1.6.2 1,288,836 5/31/2016
1.6.1 276,343 11/9/2015
1.6.0 107,442 7/13/2015
1.5.1 42,838 4/17/2015
1.5.0 33,362 2/27/2015
1.4.0 31,064 12/31/2014
1.3.1 15,121 11/18/2014
1.3.0 44,329 8/27/2014
1.2.1 7,072 7/12/2014
1.1.1.33 6,361 6/21/2014
1.1.1.26 36,115 1/4/2014
1.1.1.15 20,172 8/16/2013

Use of standard dependency injection, configuration and logging libraries.
Simplification of in-process runner configuration and instantiation.
dotnet-fm is now a global .NET Core 2.1 tool.
Minimum .NET Framework version is 4.6.1.

Details: https://github.com/fluentmigrator/fluentmigrator/releases