ErikEJ.EntityFrameworkCore.DgmlBuilder 6.0.0

.NET 6.0

Requires NuGet 5.0 or higher.

dotnet add package ErikEJ.EntityFrameworkCore.DgmlBuilder --version 6.0.0
NuGet\Install-Package ErikEJ.EntityFrameworkCore.DgmlBuilder -Version 6.0.0
This command is intended to be used within the Package Manager Console in Visual Studio, as it uses the NuGet module's version of Install-Package.
<PackageReference Include="ErikEJ.EntityFrameworkCore.DgmlBuilder" Version="6.0.0" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add ErikEJ.EntityFrameworkCore.DgmlBuilder --version 6.0.0
#r "nuget: ErikEJ.EntityFrameworkCore.DgmlBuilder, 6.0.0"
#r directive can be used in F# Interactive, C# scripting and .NET Interactive. Copy this into the interactive tool or source code of the script to reference the package.
// Install ErikEJ.EntityFrameworkCore.DgmlBuilder as a Cake Addin
#addin nuget:?package=ErikEJ.EntityFrameworkCore.DgmlBuilder&version=6.0.0

// Install ErikEJ.EntityFrameworkCore.DgmlBuilder as a Cake Tool
#tool nuget:?package=ErikEJ.EntityFrameworkCore.DgmlBuilder&version=6.0.0

Generate DGML (Graph) content that visualizes your DbContext. Adds the AsDgml() extension method to the DbContext class. Also has AsSqlScript() extension method to generate a SQL script for your current model.

Product Versions
.NET net6.0 net6.0-android net6.0-ios net6.0-maccatalyst net6.0-macos net6.0-tvos net6.0-windows
Compatible target framework(s)
Additional computed target framework(s)
Learn more about Target Frameworks and .NET Standard.

NuGet packages (1)

Showing the top 1 NuGet packages that depend on ErikEJ.EntityFrameworkCore.DgmlBuilder:

Package Downloads
OCISDK.Core

warning: The official SDK has been released by Oracle. We recommend using the official SDK in the future. Please be aware that the maintenance of this SDK will be reduced in the future. Unofficial Oracle Cloud Infrastructure SDK for .NET. Supports several APIs. This SDK is unofficial and does not support all OCI services. It is also intended for personal research and limited project use only. Please be aware that the author is not responsible for any problems that may arise from using this SDK. Please send comments and requests for this SDK to GitHub. The RC version may contain bugs. Use the official version for important work. 警告: オラクルから公式なSDKが公開されました。今後は公式なSDKの利用を推奨いたします。 また、本SDKのメンテナンスも今後は低下させていきますので、ご了承ください .Net向け非公式Oracle Cloud Infrastructure SDK。 一部のAPIにのみ対応。 本SDKは非公式であり、すべてのOCIサービスをサポートするものではありません。また、個人的な研究と限られたプロジェクトでの利用のみを想定しています。 本SDKを利用したことで発生したいかなる問題に関して作成者は責任を負いかねますのでご了承ください。 本SDKに対するご意見・ご要望はGitHubまでお願いします。 RCバージョンにはバグが含まれている場合があります。 重要な作業には公式バージョンを使用してください。

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
6.0.0 65,443 11/13/2021
5.0.0 28,379 9/8/2021
5.0.0-preview2 296 7/14/2021
5.0.0-preview1 10,341 12/30/2020
3.1.4 14,649 7/13/2021
3.1.3 294 7/13/2021
3.1.1 180,851 6/1/2020
3.1.0 4,925 4/17/2020
3.0.0 18,289 10/11/2019
2.1.1 50,262 6/20/2018
2.1.0 2,054 6/19/2018
1.0.10 1,465 4/30/2018
1.0.9 1,026 4/28/2018
1.0.7 4,673 1/5/2018

Bug fixes to generated DGML