Correlate.DependencyInjection 3.2.0

Dependency injection extensions for Correlate.

Install-Package Correlate.DependencyInjection -Version 3.2.0
dotnet add package Correlate.DependencyInjection --version 3.2.0
<PackageReference Include="Correlate.DependencyInjection" Version="3.2.0" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add Correlate.DependencyInjection --version 3.2.0
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

v3.2.0

  • Added .NET Standard 2.1 support (for .NET Core 3.x, with newer Microsoft.* dependencies)
  • Updated API contracts with non-nullable ref types
  • Fix several potential NRE's in extension methods that were not guarded with ANE's.

v3.2.0

  • Added .NET Standard 2.1 support (for .NET Core 3.x, with newer Microsoft.* dependencies)
  • Updated API contracts with non-nullable ref types
  • Fix several potential NRE's in extension methods that were not guarded with ANE's.

NuGet packages (1)

Showing the top 1 NuGet packages that depend on Correlate.DependencyInjection:

Package Downloads
Correlate.AspNetCore
ASP.NET Core middleware component to correlate requests between microservices using correlation id request headers.

GitHub repositories

This package is not used by any popular GitHub repositories.

Version History

Version Downloads Last updated
3.2.0 30,530 1/16/2020
3.1.0 7,815 9/23/2019
3.0.0 1,966 7/23/2019
2.4.0 3,823 7/2/2019
2.3.0 7,790 5/11/2019
2.2.0 855 4/7/2019
2.1.4 4,789 3/15/2019
2.1.3 173 3/15/2019
2.1.1 845 3/15/2019
2.1.0 190 3/15/2019