CCd.MemoryInterop.ILPatcher 2.2.2

dotnet add package CCd.MemoryInterop.ILPatcher --version 2.2.2
NuGet\Install-Package CCd.MemoryInterop.ILPatcher -Version 2.2.2
This command is intended to be used within the Package Manager Console in Visual Studio, as it uses the NuGet module's version of Install-Package.
<PackageReference Include="CCd.MemoryInterop.ILPatcher" Version="2.2.2">
  <PrivateAssets>all</PrivateAssets>
  <IncludeAssets>runtime; build; native; contentfiles; analyzers</IncludeAssets>
</PackageReference>
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add CCd.MemoryInterop.ILPatcher --version 2.2.2
#r "nuget: CCd.MemoryInterop.ILPatcher, 2.2.2"
#r directive can be used in F# Interactive and Polyglot Notebooks. Copy this into the interactive tool or source code of the script to reference the package.
// Install CCd.MemoryInterop.ILPatcher as a Cake Addin
#addin nuget:?package=CCd.MemoryInterop.ILPatcher&version=2.2.2

// Install CCd.MemoryInterop.ILPatcher as a Cake Tool
#tool nuget:?package=CCd.MemoryInterop.ILPatcher&version=2.2.2

A MSBuild task that scans assemblies for locations to patch in IL code that normally cannot be generated from C# (e.g. cpblk/memcpy). The majority of the stub methods available are generic, which allows for low overhead (e.g. no boxing) when working with struct types and interoping with (unmanaged) memory pointers.

The nuget package works with both PackageReference and the older nuget config format. The stub methods are served as a content file that will be added to your project with a namespace transformation. The generated code behaves similarly to the new Unsafe library, but this patcher allows you to inject that behavior directly into your own assembly, avoiding additional nuget dependencies or reliance on packing tools like ILMerge.

Note: C# 7.2 is required as of version 2.0.

There are no supported framework assets in this package.

Learn more about Target Frameworks and .NET Standard.

  • .NETStandard 2.0

    • No dependencies.

NuGet packages

This package is not used by any NuGet packages.

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
2.2.2 299 11/18/2023