Zyan.SafeDeserializationHelpers 0.4.0

Safe deserialization helper library to fix known BinaryFormatter vulnerabilities.

There is a newer version of this package available.
See the version list below for details.
Install-Package Zyan.SafeDeserializationHelpers -Version 0.4.0
dotnet add package Zyan.SafeDeserializationHelpers --version 0.4.0
<PackageReference Include="Zyan.SafeDeserializationHelpers" Version="0.4.0" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add Zyan.SafeDeserializationHelpers --version 0.4.0
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

Release Notes

What's new:

     v0.4.0:
     - UnsafeDeserializationException is serialized as plain SecurityException.
     - Zyan.SafeDeserializationHelpers assembly is not required on the client side anymore.

     v0.3.0:
     - Added more blacklisted namespaces to the delegate validator.

     v0.2.0:
     - Updated TypeFilterLevel to match the .NET defaults.

     v0.1.0:
     - Initial release.

Dependencies

This package has no dependencies.

This package is not used by any popular GitHub repositories.

Version History

Version Downloads Last updated
0.5.1 72 12/15/2019
0.5.0 1,776 5/4/2018
0.4.0 250 5/3/2018
0.3.0 1,144 4/30/2018
0.2.0 372 4/28/2018
0.1.0 264 4/27/2018