MonetDb.Mapi 2.1.1

Install-Package MonetDb.Mapi -Version 2.1.1
dotnet add package MonetDb.Mapi --version 2.1.1
<PackageReference Include="MonetDb.Mapi" Version="2.1.1" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add MonetDb.Mapi --version 2.1.1
The NuGet Team does not provide support for this client. Please contact its maintainers for support.
#r "nuget: MonetDb.Mapi, 2.1.1"
#r directive can be used in F# Interactive, C# scripting and .NET Interactive. Copy this into the interactive tool or source code of the script to reference the package.
// Install MonetDb.Mapi as a Cake Addin
#addin nuget:?package=MonetDb.Mapi&version=2.1.1

// Install MonetDb.Mapi as a Cake Tool
#tool nuget:?package=MonetDb.Mapi&version=2.1.1
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

Overview

.NET Standart Data Provider for MonetDb

https://www.nuget.org/packages/MonetDb.Mapi/

Tests included.

Supported Mapi protocols:

  • version 8
  • version 9

Versions

  • 2.1.0 Cancelling command by terminate session/connection. For this feature use MonetDbEnviroments.CommandCloseStrategy
  • 2.0.1 HugeInt DataType support
  • 2.0.0 Redirect connection, Web Api Client (.NET Core 2.2 + ReactJs).
  • 1.6.0 MonetDbConnectionStringBuilder
  • 1.5.0 Need more support, copy from stdin test
  • 1.4.1 BugFix error handler
  • 1.4.0 Large query support
  • 1.3.6 Default Isolation Level Unspecified → Serializable
  • 1.3.5 BugFix correct char dbtype
  • 1.3.4 Date parser, tests
  • 1.3.3 Data/Db types
  • 1.3.2 BugFix multiline exceptions, disposing connections, parallelling pool
  • 1.3.1 BugFix "Unrecognized {number}]"
  • 1.3 New lexer for parsing mapi data rows
  • 1.2 Change implementig System.Data interfaces to extending abstract classes: System.Data.IDb... → System.Data.Common.Db...
  • 1.1.1 double E format parsing

Web Client

Connection

Connection

Query

Query

Result

Result

Mobile result

Mobile

  • .NETStandard 2.0

    • No dependencies.

NuGet packages

This package is not used by any NuGet packages.

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
2.1.1 410 11/26/2020
2.1.0 175 11/12/2020
2.0.1 226 9/18/2020
2.0.0 944 10/30/2019
1.6.3 288 9/23/2019
1.6.2 310 8/5/2019
1.6.1 305 7/26/2019
1.6.0 275 7/26/2019
1.5.2 317 5/29/2019
1.5.1 346 5/14/2019
1.5.0 328 4/9/2019
1.4.1 316 4/8/2019
1.4.0 320 4/5/2019
1.3.6 457 12/27/2018
1.3.5 455 11/12/2018
1.3.4 459 11/7/2018
1.3.3 437 11/1/2018
1.3.2 418 10/31/2018
1.3.1 428 10/31/2018
1.3.0 424 10/26/2018
1.2.0 470 10/24/2018
1.1.1 474 9/27/2018
1.1.0 458 9/13/2018
1.0.0 467 9/12/2018