Joveler.Compression.LZ4 3.1.1

lz4 pinvoke library for .Net.
The library provides the native implementation of LZ4FrameStream.
Supports Windows, Linux and macOS.

Install-Package Joveler.Compression.LZ4 -Version 3.1.1
dotnet add package Joveler.Compression.LZ4 --version 3.1.1
<PackageReference Include="Joveler.Compression.LZ4" Version="3.1.1" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add Joveler.Compression.LZ4 --version 3.1.1
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

Usage

Please refer to this document.

The library supports many customizable options and fast decompression performance, but not in compression performance. See README.md for details.

Tested liblz4 Versions

  • 1.8.1.2
  • 1.8.2
  • 1.8.3
  • 1.9.1
  • 1.9.2 (Included)

Support

Targeted .Net platforms

  • .Net Framework 4.5.1
  • .Net Standard 2.0 (.Net Framework 4.6.1+, .Net Core 2.0+)

Supported OS platforms

  • Windows x86, x64
  • Linux x64, armhf, arm64
  • macOS x64

Usage

Please refer to this document.

The library supports many customizable options and fast decompression performance, but not in compression performance. See README.md for details.

Tested liblz4 Versions

  • 1.8.1.2
  • 1.8.2
  • 1.8.3
  • 1.9.1
  • 1.9.2 (Included)

Support

Targeted .Net platforms

  • .Net Framework 4.5.1
  • .Net Standard 2.0 (.Net Framework 4.6.1+, .Net Core 2.0+)

Supported OS platforms

  • Windows x86, x64
  • Linux x64, armhf, arm64
  • macOS x64

Release Notes

- Improve RHEL/CentOS compatibility

This package is not used by any popular GitHub repositories.

Version History

Version Downloads Last updated
3.1.1 29 10/31/2019
3.1.0 33 10/20/2019