Defunctr 1.2.0

Defunctr is a module for Modernizr that will detect the current browser using feature detection. It will then append browser informational classes to the head element of the page, giving the designer the ability to override CSS styles without using older browser hacks. Changing the browsers compatability mode will cause the correct classes to be applied and changing a user-agent will have not effect on the class generation.

There is a newer version of this package available.
See the version list below for details.
Install-Package Defunctr -Version 1.2.0
dotnet add package Defunctr --version 1.2.0
<PackageReference Include="Defunctr" Version="1.2.0" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add Defunctr --version 1.2.0
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

Release Notes

Support for Requirejs, Commonjs, and AMD environments is now supported. New detections for IE 10, 11, and 12. Detection support for Edge added. Fix for IE 11 compatabilty mode 5 being reported as multiple versions of IE.

This package is not used by any popular GitHub repositories.

Version History

Version Downloads Last updated
1.3.1 504 8/14/2017
1.3.0 339 2/10/2017
1.3.0-beta1 379 8/24/2016
1.2.3 531 5/8/2016
1.2.2 422 5/8/2016
1.2.0 865 1/14/2016
1.1.2 505 1/13/2016
1.1.1 3,230 2/28/2014
1.1.0 642 2/8/2013
1.0.0 480 2/6/2013
Show less