ContentSecurityPolicy 1.0.0

The Content Security Policy middleware for ASP.NET Core adds the Content-Security-Policy HTTP response header to reduce the risks of XSS attacks on modern browsers.

There is a newer prerelease version of this package available.
See the version list below for details.
Install-Package ContentSecurityPolicy -Version 1.0.0
dotnet add package ContentSecurityPolicy --version 1.0.0
<PackageReference Include="ContentSecurityPolicy" Version="1.0.0" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add ContentSecurityPolicy --version 1.0.0
The NuGet Team does not provide support for this client. Please contact its maintainers for support.
#r "nuget: ContentSecurityPolicy, 1.0.0"
#r directive can be used in F# Interactive, C# scripting and .NET Interactive. Copy this into the interactive tool or source code of the script to reference the package.
// Install ContentSecurityPolicy as a Cake Addin
#addin nuget:?package=ContentSecurityPolicy&version=1.0.0

// Install ContentSecurityPolicy as a Cake Tool
#tool nuget:?package=ContentSecurityPolicy&version=1.0.0
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

NuGet packages

This package is not used by any NuGet packages.

GitHub repositories

This package is not used by any popular GitHub repositories.

Version History

Version Downloads Last updated
2.0.0-alpha1 705 8/6/2017
1.0.0 3,456 6/20/2017
0.1.0-beta-0012 619 11/2/2016
0.1.0-beta-0009 630 11/2/2016
0.1.0-beta-0006 574 11/1/2016