AspNetCore.DataProtection.Aws.Kms 2.2.0

.NET Core 3.0 .NET Standard 2.0
Install-Package AspNetCore.DataProtection.Aws.Kms -Version 2.2.0
dotnet add package AspNetCore.DataProtection.Aws.Kms --version 2.2.0
<PackageReference Include="AspNetCore.DataProtection.Aws.Kms" Version="2.2.0" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add AspNetCore.DataProtection.Aws.Kms --version 2.2.0
The NuGet Team does not provide support for this client. Please contact its maintainers for support.
#r "nuget: AspNetCore.DataProtection.Aws.Kms, 2.2.0"
#r directive can be used in F# Interactive, C# scripting and .NET Interactive. Copy this into the interactive tool or source code of the script to reference the package.
// Install AspNetCore.DataProtection.Aws.Kms as a Cake Addin
#addin nuget:?package=AspNetCore.DataProtection.Aws.Kms&version=2.2.0

// Install AspNetCore.DataProtection.Aws.Kms as a Cake Tool
#tool nuget:?package=AspNetCore.DataProtection.Aws.Kms&version=2.2.0
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

ASP.NET Core DataProtection encrypter & decrypter for use with AWS KMS

Product Versions
.NET net5.0 net5.0-windows net6.0 net6.0-android net6.0-ios net6.0-maccatalyst net6.0-macos net6.0-tvos net6.0-windows
.NET Core netcoreapp2.0 netcoreapp2.1 netcoreapp2.2 netcoreapp3.0 netcoreapp3.1
.NET Standard netstandard2.0 netstandard2.1
.NET Framework net461 net462 net463 net47 net471 net472 net48
MonoAndroid monoandroid
MonoMac monomac
MonoTouch monotouch
Tizen tizen40 tizen60
Xamarin.iOS xamarinios
Xamarin.Mac xamarinmac
Xamarin.TVOS xamarintvos
Xamarin.WatchOS xamarinwatchos
Compatible target framework(s)
Additional computed target framework(s)
Learn more about Target Frameworks and .NET Standard.

NuGet packages

This package is not used by any NuGet packages.

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
2.2.0 73,059 10/15/2019
2.1.0 19,541 3/3/2019
2.0.2 59,921 4/8/2018
2.0.1 1,649 3/29/2018
2.0.0 10,416 10/15/2017
2.0.0-beta03 645 9/23/2017
2.0.0-beta02 690 8/31/2017
2.0.0-beta01 690 8/30/2017
1.0.0 2,299 8/29/2017
1.0.0-beta07 807 5/13/2017
1.0.0-beta06 1,727 3/14/2017
1.0.0-beta05 713 3/13/2017
1.0.0-beta04 1,396 12/29/2016
1.0.0-beta03 730 10/14/2016
1.0.0-beta02 708 10/1/2016
1.0.0-beta01 758 7/2/2016
1.0.0-alpha05 749 7/2/2016
1.0.0-alpha04 735 6/15/2016
1.0.0-alpha03 728 6/7/2016
1.0.0-alpha02 713 6/7/2016

Supports ASP.NET Core 2.2 and ASP.NET Core 3.0
Allows configuration via ASP.NET Configuration Binding
Integrates with DataProtection Application Discriminator
PDBs now embedded & source linked
Semantic versioning included in dependencies, restricted to minimums only

Breaking changes:
Requires NET Standard 2.0 and ASP.NET Core 2.0, or ASP.NET Core 3.0
Application ID no longer part of KMS Encryptor configuration - see README for migration notes